From: John Crispin <john@openwrt.org>
Date: Sun, 25 Jan 2009 17:28:11 +0000 (+0000)
Subject: if quilt failed whilst patching, no output was shown
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=3ec3f111ffb7484d1c5c7ad7b8b161d514e3dd65;p=openwrt%2Fstaging%2Fjow.git

if quilt failed whilst patching, no output was shown

SVN-Revision: 14178
---

diff --git a/include/quilt.mk b/include/quilt.mk
index c47a9262d9..8a63442dd2 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -126,7 +126,7 @@ define Build/Quilt
 
   $(STAMP_CONFIGURED): $(STAMP_CHECKED) FORCE
   $(STAMP_CHECKED): $(STAMP_PATCHED)
-	if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); if quilt next >/dev/null 2>&1; then quilt push -a; else quilt top; fi >/dev/null 2>&1); fi
+	if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); if quilt next >/dev/null 2>&1; then quilt push -a; else quilt top >/dev/null 2>&1; fi); fi
 	touch $$@
 
   quilt-check: $(STAMP_PREPARED) FORCE