From: Nicolas Thill <nico@openwrt.org>
Date: Sun, 10 Jul 2005 15:06:24 +0000 (+0000)
Subject: Add some missing headers to STAGING_DIR, required to build php4 extension
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=3ec895cbdda35cfd86f3795b4f5a8de8ca4e60ca;p=openwrt%2Fstaging%2Fdedeckeh.git

Add some missing headers to STAGING_DIR, required to build php4 extension

SVN-Revision: 1399
---

diff --git a/openwrt/package/postgresql/Makefile b/openwrt/package/postgresql/Makefile
index de021ba35b..1f37bb7527 100644
--- a/openwrt/package/postgresql/Makefile
+++ b/openwrt/package/postgresql/Makefile
@@ -95,6 +95,7 @@ $(IPKG_PGSQL_CLI):
 
 $(STAGING_DIR)/usr/lib/libpq.so: $(PKG_BUILD_DIR)/.built
 	mkdir -p $(STAGING_DIR)/usr/include
+	cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq $(STAGING_DIR)/usr/include/
 	cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq-fe.h $(STAGING_DIR)/usr/include/
 	cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgres_ext.h $(STAGING_DIR)/usr/include/
 	cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgresql $(STAGING_DIR)/usr/include/
@@ -106,6 +107,7 @@ install-dev: $(STAGING_DIR)/usr/lib/libpq.so
 
 uninstall-dev:
 	rm -rf \
+		$(STAGING_DIR)/usr/include/libpq \
 		$(STAGING_DIR)/usr/include/libpq-fe.h \
 		$(STAGING_DIR)/usr/include/postgres_ext.h \
 		$(STAGING_DIR)/usr/include/postgresql \