From: Felix Fietkau <nbd@nbd.name>
Date: Thu, 10 Oct 2019 11:42:56 +0000 (+0200)
Subject: build: adjust gcc/g++ version checks for newer apple compilers
X-Git-Tag: v18.06.9~51
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=401fe1a59997fd066cab878aadc2fa2d200aefef;p=openwrt%2Fstaging%2Fpepe2k.git

build: adjust gcc/g++ version checks for newer apple compilers

Signed-off-by: Felix Fietkau <nbd@nbd.name>
(cherry-picked from commit 46a129194de0f9e2f71b6526634569e1ec802504)
---

diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 79d6ae1e6c..d626ab024f 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -37,7 +37,7 @@ $(eval $(call SetupHostCommand,gcc, \
 	gcc7 --version | grep gcc, \
 	gcc8 --version | grep gcc, \
 	gcc9 --version | grep gcc, \
-	gcc --version | grep Apple.LLVM ))
+	gcc --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-gcc, \
 	\nPlease reinstall the GNU C Compiler (4.8 or later) - \
@@ -56,7 +56,7 @@ $(eval $(call SetupHostCommand,g++, \
 	g++7 --version | grep g++, \
 	g++8 --version | grep g++, \
 	g++9 --version | grep g++, \
-	g++ --version | grep Apple.LLVM ))
+	g++ --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-g++, \
 	\nPlease reinstall the GNU C++ Compiler (4.8 or later) - \