From: Florian Fainelli <florian@openwrt.org>
Date: Sat, 28 Jan 2012 13:19:43 +0000 (+0000)
Subject: refresh 3.2 patches
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=405a0f390567dc8be1b3ad598f76d77e332bdfa3;p=openwrt%2Fstaging%2Fneocturne.git

refresh 3.2 patches

SVN-Revision: 29934
---

diff --git a/target/linux/ar71xx/patches-3.2/026-MIPS-ath79-Rename-dev-ar913x-wmac.c-to-dev-wmac.c.patch b/target/linux/ar71xx/patches-3.2/026-MIPS-ath79-Rename-dev-ar913x-wmac.c-to-dev-wmac.c.patch
index c9a4ce9a1c..a89a22f981 100644
--- a/target/linux/ar71xx/patches-3.2/026-MIPS-ath79-Rename-dev-ar913x-wmac.c-to-dev-wmac.c.patch
+++ b/target/linux/ar71xx/patches-3.2/026-MIPS-ath79-Rename-dev-ar913x-wmac.c-to-dev-wmac.c.patch
@@ -20,7 +20,7 @@ Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
 
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -20,7 +20,7 @@ obj-$(CONFIG_ATH79_DEV_GPIO_BUTTONS)	+= 
+@@ -20,7 +20,7 @@ obj-$(CONFIG_ATH79_DEV_GPIO_BUTTONS)	+=
  obj-$(CONFIG_ATH79_DEV_LEDS_GPIO)	+= dev-leds-gpio.o
  obj-$(CONFIG_ATH79_DEV_SPI)		+= dev-spi.o
  obj-$(CONFIG_ATH79_DEV_USB)		+= dev-usb.o
diff --git a/target/linux/ar71xx/patches-3.2/115-MIPS-ath79-allow-to-use-board-specific-pci_plat_dev_.patch b/target/linux/ar71xx/patches-3.2/115-MIPS-ath79-allow-to-use-board-specific-pci_plat_dev_.patch
index 4a5ec6c93f..91430a4a1a 100644
--- a/target/linux/ar71xx/patches-3.2/115-MIPS-ath79-allow-to-use-board-specific-pci_plat_dev_.patch
+++ b/target/linux/ar71xx/patches-3.2/115-MIPS-ath79-allow-to-use-board-specific-pci_plat_dev_.patch
@@ -99,7 +99,7 @@ dereference, that will be fixed in a subsequent patch.
  static struct ar724x_pci_data *pci_data;
  static int pci_data_size;
  
-@@ -38,14 +39,15 @@ int __init pcibios_map_irq(const struct 
+@@ -38,14 +39,15 @@ int __init pcibios_map_irq(const struct
  
  int pcibios_plat_dev_init(struct pci_dev *dev)
  {
diff --git a/target/linux/ar71xx/patches-3.2/132-MIPS-ath79-add-PCI_AR724X-Kconfig-symbol.patch b/target/linux/ar71xx/patches-3.2/132-MIPS-ath79-add-PCI_AR724X-Kconfig-symbol.patch
index dff6969d6f..62e95df955 100644
--- a/target/linux/ar71xx/patches-3.2/132-MIPS-ath79-add-PCI_AR724X-Kconfig-symbol.patch
+++ b/target/linux/ar71xx/patches-3.2/132-MIPS-ath79-add-PCI_AR724X-Kconfig-symbol.patch
@@ -51,7 +51,7 @@ Acked-by: Luis R. Rodriguez <mcgrof@qca.qualcomm.com>
  static inline int ar724x_pcibios_init(int irq) { return 0 };
 --- a/arch/mips/pci/Makefile
 +++ b/arch/mips/pci/Makefile
-@@ -20,7 +20,7 @@ obj-$(CONFIG_BCM63XX)		+= pci-bcm63xx.o 
+@@ -20,7 +20,7 @@ obj-$(CONFIG_BCM63XX)		+= pci-bcm63xx.o
  					ops-bcm63xx.o
  obj-$(CONFIG_MIPS_ALCHEMY)	+= pci-alchemy.o
  obj-$(CONFIG_SOC_AR71XX)	+= pci-ar71xx.o
diff --git a/target/linux/ar71xx/patches-3.2/133-MIPS-ath79-add-PCI-registration-code-for-AR934X.patch b/target/linux/ar71xx/patches-3.2/133-MIPS-ath79-add-PCI-registration-code-for-AR934X.patch
index 6c9d072ac4..7f168b33e7 100644
--- a/target/linux/ar71xx/patches-3.2/133-MIPS-ath79-add-PCI-registration-code-for-AR934X.patch
+++ b/target/linux/ar71xx/patches-3.2/133-MIPS-ath79-add-PCI-registration-code-for-AR934X.patch
@@ -31,7 +31,7 @@ Acked-by: Luis R. Rodriguez <mcgrof@qca.qualcomm.com>
  #include <asm/mach-ath79/ath79.h>
  #include <asm/mach-ath79/irq.h>
  #include <asm/mach-ath79/pci.h>
-@@ -57,7 +58,9 @@ int __init pcibios_map_irq(const struct 
+@@ -57,7 +58,9 @@ int __init pcibios_map_irq(const struct
  		if (soc_is_ar71xx()) {
  			ath79_pci_irq_map = ar71xx_pci_irq_map;
  			ath79_pci_nr_irqs = ARRAY_SIZE(ar71xx_pci_irq_map);
diff --git a/target/linux/ar71xx/patches-3.2/204-spi-ath79-use-gpio_request_one.patch b/target/linux/ar71xx/patches-3.2/204-spi-ath79-use-gpio_request_one.patch
index 0484d3d7f3..1f607fd5dd 100644
--- a/target/linux/ar71xx/patches-3.2/204-spi-ath79-use-gpio_request_one.patch
+++ b/target/linux/ar71xx/patches-3.2/204-spi-ath79-use-gpio_request_one.patch
@@ -32,18 +32,19 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 -		status = gpio_request(cdata->gpio, dev_name(&spi->dev));
 -		if (status)
 -			return status;
-+		flags = GPIOF_DIR_OUT;
-+		if (spi->mode & SPI_CS_HIGH)
-+			flags |= GPIOF_INIT_HIGH;
-+		else
-+			flags |= GPIOF_INIT_LOW;
- 
+-
 -		status = gpio_direction_output(cdata->gpio,
 -					       spi->mode & SPI_CS_HIGH);
 -		if (status) {
 -			gpio_free(cdata->gpio);
 -			return status;
 -		}
++		flags = GPIOF_DIR_OUT;
++		if (spi->mode & SPI_CS_HIGH)
++			flags |= GPIOF_INIT_HIGH;
++		else
++			flags |= GPIOF_INIT_LOW;
++
 +		status = gpio_request_one(cdata->gpio, flags,
 +					  dev_name(&spi->dev));
  	}
diff --git a/target/linux/ar71xx/patches-3.2/205-spi-ath79-introduce-ath79_spi_-en-dis-able-helpers.patch b/target/linux/ar71xx/patches-3.2/205-spi-ath79-introduce-ath79_spi_-en-dis-able-helpers.patch
index bf18edead7..1324f18dc1 100644
--- a/target/linux/ar71xx/patches-3.2/205-spi-ath79-introduce-ath79_spi_-en-dis-able-helpers.patch
+++ b/target/linux/ar71xx/patches-3.2/205-spi-ath79-introduce-ath79_spi_-en-dis-able-helpers.patch
@@ -9,7 +9,7 @@ Subject: [PATCH 5/7] spi/ath79: introduce ath79_spi_{en,dis}able helpers
 
 --- a/drivers/spi/spi-ath79.c
 +++ b/drivers/spi/spi-ath79.c
-@@ -89,16 +89,8 @@ static void ath79_spi_chipselect(struct 
+@@ -89,16 +89,8 @@ static void ath79_spi_chipselect(struct
  
  }
  
@@ -53,7 +53,7 @@ Subject: [PATCH 5/7] spi/ath79: introduce ath79_spi_{en,dis}able helpers
  
  	status = 0;
  	if (spi->chip_select) {
-@@ -134,11 +145,6 @@ static void ath79_spi_cleanup_cs(struct 
+@@ -134,11 +145,6 @@ static void ath79_spi_cleanup_cs(struct
  		struct ath79_spi_controller_data *cdata = spi->controller_data;
  		gpio_free(cdata->gpio);
  	}
diff --git a/target/linux/ar71xx/patches-3.2/207-spi-ath79-make-chipselect-logic-more-flexible.patch b/target/linux/ar71xx/patches-3.2/207-spi-ath79-make-chipselect-logic-more-flexible.patch
index 7c45b73f1f..cada123cb5 100644
--- a/target/linux/ar71xx/patches-3.2/207-spi-ath79-make-chipselect-logic-more-flexible.patch
+++ b/target/linux/ar71xx/patches-3.2/207-spi-ath79-make-chipselect-logic-more-flexible.patch
@@ -38,7 +38,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  struct ath79_spi {
  	struct spi_bitbang	bitbang;
  	u32			ioc_base;
-@@ -62,6 +64,7 @@ static void ath79_spi_chipselect(struct 
+@@ -62,6 +64,7 @@ static void ath79_spi_chipselect(struct
  {
  	struct ath79_spi *sp = ath79_spidev_to_sp(spi);
  	int cs_high = (spi->mode & SPI_CS_HIGH) ? is_active : !is_active;
@@ -46,7 +46,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  
  	if (is_active) {
  		/* set initial clock polarity */
-@@ -73,20 +76,21 @@ static void ath79_spi_chipselect(struct 
+@@ -73,20 +76,21 @@ static void ath79_spi_chipselect(struct
  		ath79_spi_wr(sp, AR71XX_SPI_REG_IOC, sp->ioc_base);
  	}
  
diff --git a/target/linux/ar71xx/patches-3.2/301-leds-wndr3700-3.2-fixes.patch b/target/linux/ar71xx/patches-3.2/301-leds-wndr3700-3.2-fixes.patch
index 5171e909dc..1b5012b7db 100644
--- a/target/linux/ar71xx/patches-3.2/301-leds-wndr3700-3.2-fixes.patch
+++ b/target/linux/ar71xx/patches-3.2/301-leds-wndr3700-3.2-fixes.patch
@@ -10,7 +10,7 @@
  
  #define DRIVER_NAME	"wndr3700-led-usb"
  
-@@ -20,14 +21,14 @@ static void wndr3700_usb_led_set(struct 
+@@ -20,14 +21,14 @@ static void wndr3700_usb_led_set(struct
  				 enum led_brightness brightness)
  {
  	if (brightness)
diff --git a/target/linux/ar71xx/patches-3.2/303-rb750_nand-3.2-fixes.patch b/target/linux/ar71xx/patches-3.2/303-rb750_nand-3.2-fixes.patch
index b0434e29a7..2c222835bc 100644
--- a/target/linux/ar71xx/patches-3.2/303-rb750_nand-3.2-fixes.patch
+++ b/target/linux/ar71xx/patches-3.2/303-rb750_nand-3.2-fixes.patch
@@ -97,7 +97,7 @@
  		u32 t;
  
  		t = __raw_readl(base + AR71XX_GPIO_REG_OUT);
-@@ -236,7 +234,7 @@ static int rb750_nand_verify_buf(struct 
+@@ -236,7 +234,7 @@ static int rb750_nand_verify_buf(struct
  
  static void __init rb750_nand_gpio_init(void)
  {
diff --git a/target/linux/ar71xx/patches-3.2/306-spi-rb4xx-3.2-fixes.patch b/target/linux/ar71xx/patches-3.2/306-spi-rb4xx-3.2-fixes.patch
index cd154324d9..973b374425 100644
--- a/target/linux/ar71xx/patches-3.2/306-spi-rb4xx-3.2-fixes.patch
+++ b/target/linux/ar71xx/patches-3.2/306-spi-rb4xx-3.2-fixes.patch
@@ -39,7 +39,7 @@
  
  #ifdef RB4XX_SPI_DEBUG
  static inline void do_spi_delay(void)
-@@ -60,10 +67,11 @@ static inline void do_spi_delay(void) { 
+@@ -60,10 +67,11 @@ static inline void do_spi_delay(void) {
  
  static inline void do_spi_init(struct spi_device *spi)
  {
diff --git a/target/linux/ar71xx/patches-3.2/505-MIPS-ath79-add-ath79_gpio_function_select.patch b/target/linux/ar71xx/patches-3.2/505-MIPS-ath79-add-ath79_gpio_function_select.patch
index 9a23f7d5e4..6b09fc0a9b 100644
--- a/target/linux/ar71xx/patches-3.2/505-MIPS-ath79-add-ath79_gpio_function_select.patch
+++ b/target/linux/ar71xx/patches-3.2/505-MIPS-ath79-add-ath79_gpio_function_select.patch
@@ -10,7 +10,7 @@
  #endif /* __ATH79_COMMON_H */
 --- a/arch/mips/ath79/gpio.c
 +++ b/arch/mips/ath79/gpio.c
-@@ -184,6 +184,34 @@ void ath79_gpio_function_setup(u32 set, 
+@@ -184,6 +184,34 @@ void ath79_gpio_function_setup(u32 set,
  	spin_unlock_irqrestore(&ath79_gpio_lock, flags);
  }
  
diff --git a/target/linux/ar71xx/patches-3.2/606-MIPS-ath79-pb44-fixes.patch b/target/linux/ar71xx/patches-3.2/606-MIPS-ath79-pb44-fixes.patch
index 1f3550bc6f..6f1829fd2d 100644
--- a/target/linux/ar71xx/patches-3.2/606-MIPS-ath79-pb44-fixes.patch
+++ b/target/linux/ar71xx/patches-3.2/606-MIPS-ath79-pb44-fixes.patch
@@ -50,7 +50,7 @@
  #define PB44_GPIO_SW_RESET	(PB44_GPIO_EXP_BASE + 6)
  #define PB44_GPIO_SW_JUMP	(PB44_GPIO_EXP_BASE + 8)
  #define PB44_GPIO_LED_JUMP1	(PB44_GPIO_EXP_BASE + 9)
-@@ -92,21 +117,66 @@ static struct ath79_spi_controller_data 
+@@ -92,21 +117,66 @@ static struct ath79_spi_controller_data
  	.cs_line = 0,
  };