From: Felix Fietkau <nbd@openwrt.org>
Date: Tue, 21 Oct 2008 19:26:36 +0000 (+0000)
Subject: fix prepare error with brcm-2.4 and missing files/ (thx, thepeople)
X-Git-Tag: reboot~25379
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=40b5e7a30d3d767f5a220be3e716d6a8fe7aaa53;p=openwrt%2Fopenwrt.git

fix prepare error with brcm-2.4 and missing files/ (thx, thepeople)

SVN-Revision: 13021
---

diff --git a/include/quilt.mk b/include/quilt.mk
index c569231173..d3233d8238 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -66,9 +66,10 @@ define Build/Patch/Default
 	$(call PatchDir,$(PATCH_DIR),)
 endef
 
+kernel_files=$(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.)
 define Kernel/Patch/Default
 	rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches
-	$(CP) $(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.) $(LINUX_DIR)/
+	$(if $(kernel_files),$(CP) $(kernel_files) $(LINUX_DIR)/)
 	find $(LINUX_DIR)/ -name \*.rej -or -name \*.orig | $(XARGS) rm -f
 	$(call PatchDir,$(GENERIC_PATCH_DIR),generic/)
 	$(call PatchDir,$(PATCH_DIR),platform/)