From: Florian Eckert <fe@dev.tdt.de>
Date: Thu, 7 Nov 2019 13:31:29 +0000 (+0100)
Subject: rpcd: add respawn param
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=432ec292ccc8;p=openwrt%2Fstaging%2Fwigyori.git

rpcd: add respawn param

The rpcd service is an important service, but if the service stops
working for any reason, no one will ever respawn that service. With this
commit, the procd service will monitor if the rpcd service
is running. If the rpcd service has crashed, then
procd respawns the rpcd service.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
---

diff --git a/package/system/rpcd/Makefile b/package/system/rpcd/Makefile
index 853554b5a0..653c859ba1 100644
--- a/package/system/rpcd/Makefile
+++ b/package/system/rpcd/Makefile
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rpcd
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/rpcd.git
diff --git a/package/system/rpcd/files/rpcd.init b/package/system/rpcd/files/rpcd.init
index 447133c67a..3e9ea5bbf3 100755
--- a/package/system/rpcd/files/rpcd.init
+++ b/package/system/rpcd/files/rpcd.init
@@ -12,6 +12,7 @@ start_service() {
 
 	procd_open_instance
 	procd_set_param command "$PROG" ${socket:+-s "$socket"} ${timeout:+-t "$timeout"}
+	procd_set_param respawn ${respawn_retry:-0}
 	procd_close_instance
 }