From: John Crispin <john@openwrt.org>
Date: Sun, 11 Oct 2015 16:23:18 +0000 (+0000)
Subject: brcm2708: use mmd for overlays subdirectory
X-Git-Tag: reboot~1821
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=4412334bea9d7946cb5b0d61647d81b330c7f2a9;p=openwrt%2Fopenwrt.git

brcm2708: use mmd for overlays subdirectory

Fixes https://dev.openwrt.org/ticket/20704

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>

SVN-Revision: 47171
---

diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 3744cace58..cc0bfb0a26 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -21,12 +21,6 @@ else
   endef
 endif
 
-define Image/Prepare
-	rm -rf $(KDIR)/overlays
-	mkdir -p $(KDIR)/overlays
-	$(CP) $(DTS_DIR)/overlays/*.dtb $(KDIR)/overlays/
-endef
-
 ### Image scripts ###
 define Build/gen-cfg
 	cat config.txt > $@.config
@@ -47,7 +41,8 @@ define Build/boot-img
 	mcopy -i $@.boot $@.config ::config.txt
 	mcopy -i $@.boot $(word 1,$^) ::kernel.img
 	mcopy -i $@.boot $(DTS_DIR)/$(DEVICE_DTS).dtb ::$(DEVICE_DTS).dtb
-	mcopy -s -i $@.boot $(KDIR)/overlays ::
+	mmd -i $@.boot ::/overlays
+	mcopy -i $@.boot $(DTS_DIR)/overlays/*.dtb ::/overlays/
 endef
 
 define Build/sdcard-img