From: Felix Fietkau <nbd@openwrt.org>
Date: Tue, 9 Jul 2013 12:52:08 +0000 (+0000)
Subject: tools: add a package for findutils, Linux 3.10 need GNU xargs
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=44b17b9ef272a0c4ceabb763777b1a605fe16306;p=openwrt%2Fstaging%2Fynezz.git

tools: add a package for findutils, Linux 3.10 need GNU xargs

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 37212
---

diff --git a/tools/Makefile b/tools/Makefile
index a1e7c18bc2..40d6e18a87 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -17,6 +17,7 @@ tools-y += m4 libtool autoconf automake flex bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
 tools-y += firmware-utils patch-image patch quilt yaffs2 flock padjffs2
 tools-y += mm-macros xorg-macros xfce-macros missing-macros xz cmake scons bc
+tools-y += findutils
 tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
 tools-$(CONFIG_powerpc) += upx
 tools-$(CONFIG_TARGET_x86) += qemu
@@ -127,7 +128,6 @@ $(STAGING_DIR_HOST)/bin/stat: $(STAGING_DIR)/.prepared
 		false; \
 	fi
 
-$(eval $(call PrepareCommand,find,gfind find))
 $(eval $(call PrepareCommand,md5sum,gmd5sum md5sum $(SCRIPT_DIR)/md5sum))
 $(eval $(call PrepareCommand,cp,gcp cp))
 $(eval $(call PrepareCommand,seq,gseq seq))
diff --git a/tools/findutils/Makefile b/tools/findutils/Makefile
new file mode 100644
index 0000000000..970cff8146
--- /dev/null
+++ b/tools/findutils/Makefile
@@ -0,0 +1,20 @@
+# 
+# Copyright (C) 2006-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=findutils
+PKG_VERSION:=4.4.2
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
+PKG_MD5SUM:=351cc4adb07d54877fa15f75fb77d39f
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+$(eval $(call HostBuild))