From: Felix Fietkau <nbd@openwrt.org>
Date: Tue, 27 Oct 2009 01:11:35 +0000 (+0000)
Subject: gcc: compile libgcc and libstdc++ with -O2 instead of -Os on power pc to avoid genera... 
X-Git-Tag: reboot~22056
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=46cc3f164d866ce62b7957809333c8b587ff5558;p=openwrt%2Fstaging%2Fxback.git

gcc: compile libgcc and libstdc++ with -O2 instead of -Os on power pc to avoid generating references to gpr save/restore functions which cannot yet be resolved at this point

SVN-Revision: 18177
---

diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index 3b31127b4a..77243c5fa4 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -151,6 +151,10 @@ GCC_CONFIGURE_STAGE2:= \
 		--disable-tls \
 		--with-slibdir=$(TOOLCHAIN_DIR)/lib \
 
+ifdef CONFIG_powerpc
+  TARGET_CFLAGS := $(patsubst -Os,-O2,$(TARGET_CFLAGS))
+endif
+
 GCC_MAKE:= \
 	export SHELL="$(BASH)"; \
 	$(MAKE) \