From: Gabor Juhos <juhosg@openwrt.org>
Date: Mon, 13 Oct 2008 17:28:47 +0000 (+0000)
Subject: change mtd partition map, use rootfs_split, and generate a firmware image for the... 
X-Git-Tag: reboot~25411
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=46d856ac86d3dd78d4d88cac9909ea773b3f1901;p=openwrt%2Fopenwrt.git

change mtd partition map, use rootfs_split, and generate a firmware image for the WBD-111

SVN-Revision: 12976
---

diff --git a/target/linux/storm/config-default b/target/linux/storm/config-default
index 2ff7f47b39..7b44e84d38 100644
--- a/target/linux/storm/config-default
+++ b/target/linux/storm/config-default
@@ -138,7 +138,6 @@ CONFIG_HW_RANDOM=y
 # CONFIG_INET_ESP is not set
 # CONFIG_INET_IPCOMP is not set
 # CONFIG_INET_TUNNEL is not set
-CONFIG_INET_XFRM_MODE_BEET=m
 # CONFIG_INET_XFRM_MODE_TRANSPORT is not set
 # CONFIG_INET_XFRM_MODE_TUNNEL is not set
 # CONFIG_INET_XFRM_TUNNEL is not set
@@ -211,8 +210,6 @@ CONFIG_MTD_REDBOOT_DIRECTORY_BLOCK=-1
 CONFIG_MTD_REDBOOT_PARTS=y
 # CONFIG_MTD_REDBOOT_PARTS_READONLY is not set
 # CONFIG_MTD_ROM is not set
-# CONFIG_MTD_ROOTFS_ROOT_DEV is not set
-# CONFIG_MTD_ROOTFS_SPLIT is not set
 # CONFIG_MTD_SERIAL is not set
 CONFIG_MTD_SL2312_CFI=y
 # CONFIG_MTD_SL2312_SERIAL_ATMEL is not set
@@ -250,6 +247,7 @@ CONFIG_NET_SL351X=y
 # CONFIG_NEW_LEDS is not set
 # CONFIG_NFSD is not set
 # CONFIG_NFS_FS is not set
+CONFIG_NF_CONNTRACK=y
 # CONFIG_NLS is not set
 # CONFIG_NO_IDLE_HZ is not set
 # CONFIG_NO_IOPORT is not set
@@ -263,7 +261,6 @@ CONFIG_PCI=y
 CONFIG_PCI_SYSCALL=y
 # CONFIG_PPP_MPPE is not set
 # CONFIG_PPP_SYNC_TTY is not set
-CONFIG_PRINTK_TIME=y
 # CONFIG_PROVE_LOCKING is not set
 # CONFIG_RCU_TORTURE_TEST is not set
 CONFIG_RTC_LIB=y
diff --git a/target/linux/storm/image/Makefile b/target/linux/storm/image/Makefile
index b061c6d0ef..e94c463ec5 100644
--- a/target/linux/storm/image/Makefile
+++ b/target/linux/storm/image/Makefile
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -19,23 +19,28 @@ define Image/BuildKernel
 #	BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh
 endef
 
-define Image/Build
-	$(call Image/Build/$(1),$(1))
-endef
-
 define Image/Build/jffs2-64k
-	dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=65536 conv=sync
+	dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=64k conv=sync
 endef
 
 define Image/Build/jffs2-128k
-	dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
-	$(call Image/Build/slug,$(1))
+	dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=128k conv=sync
 endef
 
 define Image/Build/squashfs
-    $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
-	dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
-	$(call Image/Build/slug,$(1))
+	$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+	$(call Image/Build/$(1),$(1))
+	dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+
+	-$(STAGING_DIR_HOST)/bin/mkfwimage2 \
+		-m GEOS -f 0x30000000 -z \
+		-v WILI-S.WILIBOARD.v5.00.SL3512.OpenWrt.00000.000000.000000 \
+		-o $(BIN_DIR)/openwrt-$(BOARD)-wbd-111-$(1).bin \
+		-p Kernel:0x020000:0x100000:0:0:$(BIN_DIR)/openwrt-$(BOARD)-zImage \
+		-p Ramdisk:0x120000:0x500000:0:0:$(BIN_DIR)/openwrt-$(BOARD)-root.$(1)
 endef
 
 $(eval $(call BuildImage))
diff --git a/target/linux/storm/patches/007-mtd.patch b/target/linux/storm/patches/007-mtd.patch
index 8e397bc620..d6c6d56813 100644
--- a/target/linux/storm/patches/007-mtd.patch
+++ b/target/linux/storm/patches/007-mtd.patch
@@ -1943,7 +1943,7 @@
 +
 --- /dev/null
 +++ b/drivers/mtd/maps/sl2312_flashmap.h
-@@ -0,0 +1,21 @@
+@@ -0,0 +1,20 @@
 +/*
 + * Please note that the name are used in mkflash script. Therefore
 + * don't change them.  If you want to add different partitions, you
@@ -1959,8 +1959,7 @@
 +static struct mtd_partition sl2312_partitions[] = {
 +	{ name: "RedBoot", 	 offset: 0x00000000, size: 0x00020000, },
 +	{ name: "kernel", 	 offset: 0x00020000, size: 0x00100000, },
-+	{ name: "rootfs", 	 offset: 0x00120000, size: 0x00500000, },
-+	{ name: "rootfs_data", 	 offset: 0x00620000, size: 0x001A0000, },
++	{ name: "rootfs", 	 offset: 0x00120000, size: 0x006A0000, },
 +	{ name: "VCTL", 	 offset: 0x007C0000, size: 0x00010000, },
 +	{ name: "cfg", 	 	 offset: 0x007D0000, size: 0x00020000, },
 +	{ name: "FIS directory", offset: 0x007F0000, size: 0x00010000, }