From: Jonas Gorski <jogo@openwrt.org>
Date: Mon, 1 Aug 2011 09:32:01 +0000 (+0000)
Subject: gdb: add dependency to libexpat when present
X-Git-Tag: reboot~16132
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=478decc60bb34144cc60b61c27378d8b0a0dce9b;p=openwrt%2Fstaging%2Fxback.git

gdb: add dependency to libexpat when present

Also prevent gdb from trying to link against the host's libexpat.

SVN-Revision: 27859
---

diff --git a/package/gdb/Makefile b/package/gdb/Makefile
index 671340dddd..e3cd6860be 100644
--- a/package/gdb/Makefile
+++ b/package/gdb/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
 PKG_VERSION:=6.8
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@GNU/gdb
@@ -29,7 +29,7 @@ endef
 define Package/gdb
 $(call Package/gdb/Default)
   TITLE:=GNU Debugger
-  DEPENDS+=+libreadline +libncurses
+  DEPENDS+=+libreadline +libncurses +PACKAGE_libexpat:libexpat
 endef
 
 define Package/gdb/description
@@ -51,6 +51,7 @@ endef
 # XXX: add --disable-werror to prevent build failure with arm
 CONFIGURE_ARGS+= \
 	--with-system-readline \
+	--without-libexpat-prefix \
 	--disable-werror
 
 CONFIGURE_VARS+= \