From: Felix Fietkau <nbd@openwrt.org>
Date: Mon, 5 Oct 2015 14:11:30 +0000 (+0000)
Subject: build: include homebrew include/library directory in cflags/ldflags on mac os x
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=48374a3a9c555fd0c6b57a239546c6335fab9dc0;p=openwrt%2Fstaging%2Fnbd.git

build: include homebrew include/library directory in cflags/ldflags on mac os x

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 47139
---

diff --git a/include/host-build.mk b/include/host-build.mk
index 760d38b371..e2b5f2f8d1 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -50,6 +50,11 @@ define Host/Prepare
   $(call Host/Prepare/Default)
 endef
 
+ifeq ($(HOST_OS),Darwin)
+  HOST_CFLAGS += -I/usr/local/opt/openssl/include
+  HOST_LDFLAGS += -L/usr/local/opt/openssl/lib
+endif
+
 HOST_CONFIGURE_VARS = \
 	CC="$(HOSTCC)" \
 	CFLAGS="$(HOST_CFLAGS)" \