From: Jo-Philipp Wich <jo@mein.io>
Date: Thu, 21 Apr 2016 14:34:39 +0000 (+0200)
Subject: sdk: bundle required firmware files
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=484cb91ad597c1a1019355b773a588d6e7f45a8d;p=openwrt%2Fstaging%2Fansuel.git

sdk: bundle required firmware files

Bundle all firmware files which have been built along with the kernel to fix
packaging of kmods in the SDK environment that rely on in-tree firmwares,
specifically kmod-e100.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---

diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index 7f277f9aff..f32b02b536 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -70,6 +70,8 @@ $(BIN_DIR)/$(SDK_NAME).tar.bz2: clean
 	$(CP) $(INCLUDE_DIR) $(SCRIPT_DIR) $(TOPDIR)/docs $(SDK_BUILD_DIR)/
 	$(TAR) -cf - -C $(TOPDIR) \
 		`cd $(TOPDIR); find $(KDIR_BASE) -name \*.ko` \
+		`cd $(TOPDIR); find $(KDIR_BASE)/firmware/ -newer $(KDIR_BASE)/firmware/Makefile \
+			-type f -name '*.bin' -or -name '*.cis' -or -name '*.csp' -or -name '*.dsp' -or -name '*.fw'` \
 		$(foreach exclude,$(EXCLUDE_DIRS),--exclude="$(exclude)") \
 		$(SDK_DIRS) $(KERNEL_FILES) | \
 		$(TAR) -xf - -C $(SDK_BUILD_DIR)