From: Felix Fietkau <nbd@openwrt.org>
Date: Wed, 20 Jul 2011 08:47:19 +0000 (+0000)
Subject: comgt: clean up patch, rename gcom binary to comgt, but add a compatibility symlink
X-Git-Tag: reboot~16217
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=49b905a2cf884c01aac3a863c981af4abf6ac6c8;p=openwrt%2Fstaging%2Fxback.git

comgt: clean up patch, rename gcom binary to comgt, but add a compatibility symlink

SVN-Revision: 27699
---

diff --git a/package/comgt/Makefile b/package/comgt/Makefile
index 00c1118113..61c123a737 100644
--- a/package/comgt/Makefile
+++ b/package/comgt/Makefile
@@ -37,12 +37,14 @@ define Build/Compile
 	$(MAKE) -C $(PKG_BUILD_DIR) \
 		$(TARGET_CONFIGURE_OPTS) \
 		CFLAGS="$(TARGET_CFLAGS)" \
-		gcom
+		LDFLAGS="" \
+		comgt
 endef
-	
+
 define Package/comgt/install
 	$(INSTALL_DIR) $(1)/usr/bin
-	$(INSTALL_BIN) $(PKG_BUILD_DIR)/gcom $(1)/usr/bin/
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/comgt $(1)/usr/bin/
+	ln -s comgt $(1)/usr/bin/gcom
 	$(INSTALL_DIR) $(1)/etc/ppp
 	$(INSTALL_BIN) ./files/3g.connect $(1)/etc/ppp/3g.connect
 	$(INSTALL_DIR) $(1)/etc/chatscripts
diff --git a/package/comgt/patches/001-Makefile.patch b/package/comgt/patches/001-Makefile.patch
deleted file mode 100644
index ed3e9183d1..0000000000
--- a/package/comgt/patches/001-Makefile.patch
+++ /dev/null
@@ -1,88 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -1,7 +1,6 @@
- #
--#   Makefile - build and install the comgt package
-+#   Makefile - build and install the gmon package
- #   Copyright (C) 2005  Martin Gregorie
--#   Copyright (C) 2006  Paul Hardwick
- #
- #   This program is free software; you can redistribute it and/or modify
- #   it under the terms of the GNU General Public License as published by
-@@ -17,63 +16,41 @@
- #    along with this program; if not, write to the Free Software
- #    Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
- #
--#    martin@gregorie.org, paul@peck.org.uk
-+#    martin@gregorie.org
- #
--#    $Id: Makefile,v 1.4 2006/10/20 14:30:19 pharscape Exp $
-+#	$Id$
- #
--#
--
--LIB     = -L/usr/local/lib
--INC     = -I/usr/local/include
- EXE	= /usr/local/bin
- MAN     = /usr/share/man/man1
--CPROG	= comgt
--SCRIPTPATH = /etc/comgt/
--SCRIPTSRC = ./scripts/
--BIN     = $(CPROG) 
--MANP	= comgt.1 sigmon.1
--
--CFLAGS  = -c
--LDFLAGS =
-+CPROG	= gcom
-+SCRIPT  = sigmon
-+BIN     = $(CPROG) $(SCRIPT)
-+MANP	= gcom.1 sigmon.1
- 
- all: $(BIN)
- 
- install:
-+	mv ($BIN} {$BIN2}
- 	chmod a-w $(BIN)
- 	chmod u+rw $(BIN)
- 	chmod a+x $(BIN)
--	cp $(BIN) $(EXE)
-+	cp $(BIN) $(EXE)/gcom
- 	chmod a-wx $(MANP)
- 	chmod u+rw $(MANP)
- 	chmod a+r $(MANP)
- 	cp $(MANP) $(MAN)
--	-mkdir $(SCRIPTPATH)
--	chmod a-w $(SCRIPTPATH)
--	chmod u+rw $(SCRIPTPATH)
--	chmod a+x $(SCRIPTPATH)
--	cp -f $(SCRIPTSRC)* $(SCRIPTPATH)
--	chmod a-w $(SCRIPTPATH)*
--	chmod u+rw $(SCRIPTPATH)*
--	chmod a+x $(SCRIPTPATH)*
--
--
--
- 
- uninstall:
- 	cd $(EXE); rm $(BIN)
- 	cd $(MAN); rm $(MANP)
--	-rm -r $(SCRIPTPATH)
- 
- clean:
--	-rm *.o 
--	-rm $(CPROG) 
--	-rm *~
--	-rm $(SCRIPTSRC)*~
-+	rm *.o $(CPROG)
- 
- 
--comgt: comgt.o
--	cc comgt.o $(LDFLAGS) -o comgt
-+gcom: gcom.o
-+	$(CC) gcom.o $(LDFLAGS) -o gcom
- 
--comgt.o: comgt.c comgt.h
--	cc comgt.c $(CFLAGS) 
-+gcom.o: comgt.c comgt.h
-+	$(CC) -c $(CFLAGS) comgt.c -o gcom.o
- 
diff --git a/package/comgt/patches/001-compile_fix.patch b/package/comgt/patches/001-compile_fix.patch
new file mode 100644
index 0000000000..15de850b73
--- /dev/null
+++ b/package/comgt/patches/001-compile_fix.patch
@@ -0,0 +1,23 @@
+--- a/Makefile
++++ b/Makefile
+@@ -32,6 +32,7 @@ SCRIPTPATH = /etc/comgt/
+ SCRIPTSRC = ./scripts/
+ BIN     = $(CPROG) 
+ MANP	= comgt.1 sigmon.1
++CC	= cc
+ 
+ CFLAGS  = -c
+ LDFLAGS =
+@@ -70,10 +71,5 @@ clean:
+ 	-rm *~
+ 	-rm $(SCRIPTSRC)*~
+ 
+-
+-comgt: comgt.o
+-	cc comgt.o $(LDFLAGS) -o comgt
+-
+-comgt.o: comgt.c comgt.h
+-	cc comgt.c $(CFLAGS) 
+-
++comgt:  comgt.c comgt.h
++	$(CC) $(CFLAGS) -o comgt $< $(LDFLAGS)