From: John Crispin <john@openwrt.org>
Date: Mon, 23 Apr 2012 09:37:50 +0000 (+0000)
Subject: scanning kernel packages for targets
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=4a7d620950e2f572abf04ced418371e4da07b3f4;p=openwrt%2Fstaging%2Fdangole.git

scanning kernel packages for targets

Any modifications in target/linux/*/modules.mk would not come into effect for
subsequent "make menuconfig" unless we delete ./tmp.

Signed-off-by: kalyan <kalyanatejaswi@gmail.com>

SVN-Revision: 31442
---

diff --git a/package/kernel/Makefile b/package/kernel/Makefile
index e094c601ef..8050817392 100644
--- a/package/kernel/Makefile
+++ b/package/kernel/Makefile
@@ -12,7 +12,7 @@ PKG_NAME:=kernel
 PKG_FLAGS:=hold
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/packages
-SCAN_DEPS=modules/*.mk
+SCAN_DEPS=modules/*.mk $(TOPDIR)/target/linux/*/modules.mk
 
 include $(INCLUDE_DIR)/package.mk
 ifeq ($(DUMP),)