From: Felix Fietkau <nbd@openwrt.org>
Date: Sun, 19 Oct 2014 21:45:58 +0000 (+0000)
Subject: toolchain: when using musl, install a symlink from ld-musl-*.so to /usr/bin/ldd
X-Git-Tag: reboot~5600
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=4c4157e2878f90faea20c50d06b71783a9d2c15f;p=openwrt%2Fstaging%2Fpepe2k.git

toolchain: when using musl, install a symlink from ld-musl-*.so to /usr/bin/ldd

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 42974
---

diff --git a/package/libs/toolchain/Makefile b/package/libs/toolchain/Makefile
index 72ce6b90e1..1de0c2807a 100644
--- a/package/libs/toolchain/Makefile
+++ b/package/libs/toolchain/Makefile
@@ -468,13 +468,14 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
   LD_MUSL_NAME = $(notdir $(firstword $(wildcard $(TOOLCHAIN_DIR)/lib/ld-musl-*.so*)))
 
   define Package/musl/install
-	$(INSTALL_DIR) $(1)/lib
+	$(INSTALL_DIR) $(1)/lib $(1)/usr/bin
 	$(CP) \
 		$(TOOLCHAIN_DIR)/lib/ld-musl-*.so* \
 		$(1)/lib/
 	$(CP) \
 		$(TOOLCHAIN_DIR)/lib/libc.so* \
 		$(1)/lib/
+	ln -s ../../lib/$(LD_MUSL_NAME) $(1)/usr/bin/ldd
 	$(if $(findstring -sf.so,$(LD_MUSL_NAME)),ln -s $(LD_MUSL_NAME) $(1)/lib/$(subst -sf.so,.so,$(LD_MUSL_NAME)))
   endef