From: Rosen Penev <rosenp@gmail.com>
Date: Mon, 31 Jan 2022 02:52:15 +0000 (-0800)
Subject: include/meson: fix host build directory
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=4c42e2d9dda739baa6a144cdb009aef1a33824a0;p=openwrt%2Fstaging%2Fxback.git

include/meson: fix host build directory

When using a non default MESON_HOST_BUILD_DIR, HOST_BUILD_DIR is not
appropriate to use. This change matches the target configure section.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
---

diff --git a/include/meson.mk b/include/meson.mk
index e101de4d89..102e74b542 100644
--- a/include/meson.mk
+++ b/include/meson.mk
@@ -98,7 +98,7 @@ define Host/Configure/Meson
 		--native-file $(HOST_BUILD_DIR)/openwrt-native.txt \
 		$(MESON_HOST_ARGS) \
 		$(MESON_HOST_BUILD_DIR) \
-		$(HOST_BUILD_DIR), \
+		$(MESON_HOST_BUILD_DIR)/.., \
 		$(MESON_HOST_VARS))
 endef