From: Imre Kaloz <kaloz@openwrt.org>
Date: Mon, 26 Oct 2009 10:15:52 +0000 (+0000)
Subject: rename some patches
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=4d1bd56f33944d6c6479335f15427b0542a03b94;p=openwrt%2Fstaging%2Flinusw.git

rename some patches

SVN-Revision: 18161
---

diff --git a/target/linux/generic-2.6/patches-2.6.30/004-extra_optimization.patch b/target/linux/generic-2.6/patches-2.6.30/004-extra_optimization.patch
deleted file mode 100644
index 0b5174cbbd..0000000000
--- a/target/linux/generic-2.6/patches-2.6.30/004-extra_optimization.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -529,7 +529,7 @@ all: vmlinux
- ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
- KBUILD_CFLAGS	+= -Os
- else
--KBUILD_CFLAGS	+= -O2
-+KBUILD_CFLAGS	+= -O2 -fno-reorder-blocks -fno-tree-ch
- endif
- 
- include $(srctree)/arch/$(SRCARCH)/Makefile
-@@ -567,6 +567,9 @@ endif
- NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
- CHECKFLAGS     += $(NOSTDINC_FLAGS)
- 
-+# improve gcc optimization
-+CFLAGS += $(call cc-option,-funit-at-a-time,)
-+
- # warn about C99 declaration after statement
- KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
- 
diff --git a/target/linux/generic-2.6/patches-2.6.30/006-gcc4_inline_fix.patch b/target/linux/generic-2.6/patches-2.6.30/006-gcc4_inline_fix.patch
deleted file mode 100644
index 642f11b21f..0000000000
--- a/target/linux/generic-2.6/patches-2.6.30/006-gcc4_inline_fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/arch/mips/include/asm/system.h
-+++ b/arch/mips/include/asm/system.h
-@@ -187,7 +187,7 @@ extern __u64 __xchg_u64_unsupported_on_3
-    if something tries to do an invalid xchg().  */
- extern void __xchg_called_with_bad_pointer(void);
- 
--static inline unsigned long __xchg(unsigned long x, volatile void * ptr, int size)
-+static __always_inline unsigned long __xchg(unsigned long x, volatile void * ptr, int size)
- {
- 	switch (size) {
- 	case 4:
diff --git a/target/linux/generic-2.6/patches-2.6.30/007-samsung_flash.patch b/target/linux/generic-2.6/patches-2.6.30/007-samsung_flash.patch
deleted file mode 100644
index 5c835081b8..0000000000
--- a/target/linux/generic-2.6/patches-2.6.30/007-samsung_flash.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/drivers/mtd/chips/cfi_cmdset_0002.c
-+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -51,6 +51,7 @@
- #define SST49LF040B	        0x0050
- #define SST49LF008A		0x005a
- #define AT49BV6416		0x00d6
-+#define MANUFACTURER_SAMSUNG	0x00ec
- 
- static int cfi_amdstd_read (struct mtd_info *, loff_t, size_t, size_t *, u_char *);
- static int cfi_amdstd_write_words(struct mtd_info *, loff_t, size_t, size_t *, const u_char *);
-@@ -386,12 +387,19 @@ struct mtd_info *cfi_cmdset_0002(struct 
- 
- 		if (extp->MajorVersion != '1' ||
- 		    (extp->MinorVersion < '0' || extp->MinorVersion > '4')) {
--			printk(KERN_ERR "  Unknown Amd/Fujitsu Extended Query "
--			       "version %c.%c.\n",  extp->MajorVersion,
--			       extp->MinorVersion);
--			kfree(extp);
--			kfree(mtd);
--			return NULL;
-+		        if (cfi->mfr == MANUFACTURER_SAMSUNG &&
-+			    (extp->MajorVersion == '3' && extp->MinorVersion == '3')) {
-+			    printk(KERN_NOTICE "  Newer Samsung flash detected, "
-+			           "should be compatibile with Amd/Fujitsu.\n");
-+		        }
-+		        else {
-+			    printk(KERN_ERR "  Unknown Amd/Fujitsu Extended Query "
-+			           "version %c.%c.\n",  extp->MajorVersion,
-+			           extp->MinorVersion);
-+			    kfree(extp);
-+			    kfree(mtd);
-+			    return NULL;
-+		        }
- 		}
- 
- 		/* Install our own private info structure */
diff --git a/target/linux/generic-2.6/patches-2.6.30/012-extra_optimization.patch b/target/linux/generic-2.6/patches-2.6.30/012-extra_optimization.patch
new file mode 100644
index 0000000000..0b5174cbbd
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.30/012-extra_optimization.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -529,7 +529,7 @@ all: vmlinux
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+ KBUILD_CFLAGS	+= -Os
+ else
+-KBUILD_CFLAGS	+= -O2
++KBUILD_CFLAGS	+= -O2 -fno-reorder-blocks -fno-tree-ch
+ endif
+ 
+ include $(srctree)/arch/$(SRCARCH)/Makefile
+@@ -567,6 +567,9 @@ endif
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS     += $(NOSTDINC_FLAGS)
+ 
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+ 
diff --git a/target/linux/generic-2.6/patches-2.6.30/013-gcc4_inline_fix.patch b/target/linux/generic-2.6/patches-2.6.30/013-gcc4_inline_fix.patch
new file mode 100644
index 0000000000..642f11b21f
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.30/013-gcc4_inline_fix.patch
@@ -0,0 +1,11 @@
+--- a/arch/mips/include/asm/system.h
++++ b/arch/mips/include/asm/system.h
+@@ -187,7 +187,7 @@ extern __u64 __xchg_u64_unsupported_on_3
+    if something tries to do an invalid xchg().  */
+ extern void __xchg_called_with_bad_pointer(void);
+ 
+-static inline unsigned long __xchg(unsigned long x, volatile void * ptr, int size)
++static __always_inline unsigned long __xchg(unsigned long x, volatile void * ptr, int size)
+ {
+ 	switch (size) {
+ 	case 4:
diff --git a/target/linux/generic-2.6/patches-2.6.30/014-samsung_flash b/target/linux/generic-2.6/patches-2.6.30/014-samsung_flash
new file mode 100644
index 0000000000..5c835081b8
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.30/014-samsung_flash
@@ -0,0 +1,36 @@
+--- a/drivers/mtd/chips/cfi_cmdset_0002.c
++++ b/drivers/mtd/chips/cfi_cmdset_0002.c
+@@ -51,6 +51,7 @@
+ #define SST49LF040B	        0x0050
+ #define SST49LF008A		0x005a
+ #define AT49BV6416		0x00d6
++#define MANUFACTURER_SAMSUNG	0x00ec
+ 
+ static int cfi_amdstd_read (struct mtd_info *, loff_t, size_t, size_t *, u_char *);
+ static int cfi_amdstd_write_words(struct mtd_info *, loff_t, size_t, size_t *, const u_char *);
+@@ -386,12 +387,19 @@ struct mtd_info *cfi_cmdset_0002(struct 
+ 
+ 		if (extp->MajorVersion != '1' ||
+ 		    (extp->MinorVersion < '0' || extp->MinorVersion > '4')) {
+-			printk(KERN_ERR "  Unknown Amd/Fujitsu Extended Query "
+-			       "version %c.%c.\n",  extp->MajorVersion,
+-			       extp->MinorVersion);
+-			kfree(extp);
+-			kfree(mtd);
+-			return NULL;
++		        if (cfi->mfr == MANUFACTURER_SAMSUNG &&
++			    (extp->MajorVersion == '3' && extp->MinorVersion == '3')) {
++			    printk(KERN_NOTICE "  Newer Samsung flash detected, "
++			           "should be compatibile with Amd/Fujitsu.\n");
++		        }
++		        else {
++			    printk(KERN_ERR "  Unknown Amd/Fujitsu Extended Query "
++			           "version %c.%c.\n",  extp->MajorVersion,
++			           extp->MinorVersion);
++			    kfree(extp);
++			    kfree(mtd);
++			    return NULL;
++		        }
+ 		}
+ 
+ 		/* Install our own private info structure */
diff --git a/target/linux/generic-2.6/patches-2.6.31/004-extra_optimization.patch b/target/linux/generic-2.6/patches-2.6.31/004-extra_optimization.patch
deleted file mode 100644
index e0ba51598e..0000000000
--- a/target/linux/generic-2.6/patches-2.6.31/004-extra_optimization.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -521,7 +521,7 @@ all: vmlinux
- ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
- KBUILD_CFLAGS	+= -Os
- else
--KBUILD_CFLAGS	+= -O2
-+KBUILD_CFLAGS	+= -O2 -fno-reorder-blocks -fno-tree-ch
- endif
- 
- include $(srctree)/arch/$(SRCARCH)/Makefile
-@@ -559,6 +559,9 @@ endif
- NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
- CHECKFLAGS     += $(NOSTDINC_FLAGS)
- 
-+# improve gcc optimization
-+CFLAGS += $(call cc-option,-funit-at-a-time,)
-+
- # warn about C99 declaration after statement
- KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
- 
diff --git a/target/linux/generic-2.6/patches-2.6.31/006-gcc4_inline_fix.patch b/target/linux/generic-2.6/patches-2.6.31/006-gcc4_inline_fix.patch
deleted file mode 100644
index 642f11b21f..0000000000
--- a/target/linux/generic-2.6/patches-2.6.31/006-gcc4_inline_fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/arch/mips/include/asm/system.h
-+++ b/arch/mips/include/asm/system.h
-@@ -187,7 +187,7 @@ extern __u64 __xchg_u64_unsupported_on_3
-    if something tries to do an invalid xchg().  */
- extern void __xchg_called_with_bad_pointer(void);
- 
--static inline unsigned long __xchg(unsigned long x, volatile void * ptr, int size)
-+static __always_inline unsigned long __xchg(unsigned long x, volatile void * ptr, int size)
- {
- 	switch (size) {
- 	case 4:
diff --git a/target/linux/generic-2.6/patches-2.6.31/007-samsung_flash.patch b/target/linux/generic-2.6/patches-2.6.31/007-samsung_flash.patch
deleted file mode 100644
index 5c835081b8..0000000000
--- a/target/linux/generic-2.6/patches-2.6.31/007-samsung_flash.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/drivers/mtd/chips/cfi_cmdset_0002.c
-+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -51,6 +51,7 @@
- #define SST49LF040B	        0x0050
- #define SST49LF008A		0x005a
- #define AT49BV6416		0x00d6
-+#define MANUFACTURER_SAMSUNG	0x00ec
- 
- static int cfi_amdstd_read (struct mtd_info *, loff_t, size_t, size_t *, u_char *);
- static int cfi_amdstd_write_words(struct mtd_info *, loff_t, size_t, size_t *, const u_char *);
-@@ -386,12 +387,19 @@ struct mtd_info *cfi_cmdset_0002(struct 
- 
- 		if (extp->MajorVersion != '1' ||
- 		    (extp->MinorVersion < '0' || extp->MinorVersion > '4')) {
--			printk(KERN_ERR "  Unknown Amd/Fujitsu Extended Query "
--			       "version %c.%c.\n",  extp->MajorVersion,
--			       extp->MinorVersion);
--			kfree(extp);
--			kfree(mtd);
--			return NULL;
-+		        if (cfi->mfr == MANUFACTURER_SAMSUNG &&
-+			    (extp->MajorVersion == '3' && extp->MinorVersion == '3')) {
-+			    printk(KERN_NOTICE "  Newer Samsung flash detected, "
-+			           "should be compatibile with Amd/Fujitsu.\n");
-+		        }
-+		        else {
-+			    printk(KERN_ERR "  Unknown Amd/Fujitsu Extended Query "
-+			           "version %c.%c.\n",  extp->MajorVersion,
-+			           extp->MinorVersion);
-+			    kfree(extp);
-+			    kfree(mtd);
-+			    return NULL;
-+		        }
- 		}
- 
- 		/* Install our own private info structure */
diff --git a/target/linux/generic-2.6/patches-2.6.31/012-extra_optimization.patch b/target/linux/generic-2.6/patches-2.6.31/012-extra_optimization.patch
new file mode 100644
index 0000000000..e0ba51598e
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.31/012-extra_optimization.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -521,7 +521,7 @@ all: vmlinux
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+ KBUILD_CFLAGS	+= -Os
+ else
+-KBUILD_CFLAGS	+= -O2
++KBUILD_CFLAGS	+= -O2 -fno-reorder-blocks -fno-tree-ch
+ endif
+ 
+ include $(srctree)/arch/$(SRCARCH)/Makefile
+@@ -559,6 +559,9 @@ endif
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS     += $(NOSTDINC_FLAGS)
+ 
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+ 
diff --git a/target/linux/generic-2.6/patches-2.6.31/013-gcc4_inline_fix.patch b/target/linux/generic-2.6/patches-2.6.31/013-gcc4_inline_fix.patch
new file mode 100644
index 0000000000..642f11b21f
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.31/013-gcc4_inline_fix.patch
@@ -0,0 +1,11 @@
+--- a/arch/mips/include/asm/system.h
++++ b/arch/mips/include/asm/system.h
+@@ -187,7 +187,7 @@ extern __u64 __xchg_u64_unsupported_on_3
+    if something tries to do an invalid xchg().  */
+ extern void __xchg_called_with_bad_pointer(void);
+ 
+-static inline unsigned long __xchg(unsigned long x, volatile void * ptr, int size)
++static __always_inline unsigned long __xchg(unsigned long x, volatile void * ptr, int size)
+ {
+ 	switch (size) {
+ 	case 4:
diff --git a/target/linux/generic-2.6/patches-2.6.31/014-samsung_flash b/target/linux/generic-2.6/patches-2.6.31/014-samsung_flash
new file mode 100644
index 0000000000..5c835081b8
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.31/014-samsung_flash
@@ -0,0 +1,36 @@
+--- a/drivers/mtd/chips/cfi_cmdset_0002.c
++++ b/drivers/mtd/chips/cfi_cmdset_0002.c
+@@ -51,6 +51,7 @@
+ #define SST49LF040B	        0x0050
+ #define SST49LF008A		0x005a
+ #define AT49BV6416		0x00d6
++#define MANUFACTURER_SAMSUNG	0x00ec
+ 
+ static int cfi_amdstd_read (struct mtd_info *, loff_t, size_t, size_t *, u_char *);
+ static int cfi_amdstd_write_words(struct mtd_info *, loff_t, size_t, size_t *, const u_char *);
+@@ -386,12 +387,19 @@ struct mtd_info *cfi_cmdset_0002(struct 
+ 
+ 		if (extp->MajorVersion != '1' ||
+ 		    (extp->MinorVersion < '0' || extp->MinorVersion > '4')) {
+-			printk(KERN_ERR "  Unknown Amd/Fujitsu Extended Query "
+-			       "version %c.%c.\n",  extp->MajorVersion,
+-			       extp->MinorVersion);
+-			kfree(extp);
+-			kfree(mtd);
+-			return NULL;
++		        if (cfi->mfr == MANUFACTURER_SAMSUNG &&
++			    (extp->MajorVersion == '3' && extp->MinorVersion == '3')) {
++			    printk(KERN_NOTICE "  Newer Samsung flash detected, "
++			           "should be compatibile with Amd/Fujitsu.\n");
++		        }
++		        else {
++			    printk(KERN_ERR "  Unknown Amd/Fujitsu Extended Query "
++			           "version %c.%c.\n",  extp->MajorVersion,
++			           extp->MinorVersion);
++			    kfree(extp);
++			    kfree(mtd);
++			    return NULL;
++		        }
+ 		}
+ 
+ 		/* Install our own private info structure */