From: Nicolas Thill <nico@openwrt.org>
Date: Thu, 3 Nov 2005 04:28:44 +0000 (+0000)
Subject: disable alsa and openswan on brcm-2.6
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=4d2c00455f9e51acb74f649615c2403ebcd72beb;p=openwrt%2Fstaging%2Fdedeckeh.git

disable alsa and openswan on brcm-2.6

SVN-Revision: 2321
---

diff --git a/openwrt/target/linux/package/Makefile b/openwrt/target/linux/package/Makefile
index db63d4f577..a3d06b71d1 100644
--- a/openwrt/target/linux/package/Makefile
+++ b/openwrt/target/linux/package/Makefile
@@ -2,13 +2,17 @@
 include $(TOPDIR)/rules.mk
 
 ifneq ($(BOARD),ar7)
+ifneq ($(BOARD)-$(KERNEL),brcm-2.6)
 package-$(BR2_PACKAGE_KMOD_ALSA) += alsa
 endif
+endif
 package-$(BR2_PACKAGE_KMOD_FUSE) += fuse
 package-$(BR2_PACKAGE_KMOD_HOSTAP) += hostap
 package-$(BR2_PACKAGE_KMOD_MADWIFI) += madwifi
 package-$(BR2_PACKAGE_KMOD_MINI_FO) += mini_fo
+ifneq ($(BOARD)-$(KERNEL),brcm-2.6)
 package-$(BR2_PACKAGE_KMOD_OPENSWAN) += openswan
+endif
 package-$(BR2_PACKAGE_KMOD_SHFS) += shfs
 package-y += base-files
 
diff --git a/openwrt/target/linux/package/alsa/Config.in b/openwrt/target/linux/package/alsa/Config.in
index 62dd21b97a..a68be7a6ad 100644
--- a/openwrt/target/linux/package/alsa/Config.in
+++ b/openwrt/target/linux/package/alsa/Config.in
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_KMOD_ALSA
 	prompt "kmod-alsa......................... Alsa Sound Drivers"
+	prompt "kmod-alsa......................... Alsa Sound Drivers (FIXME, does not build on 2.6/mipsel)" if BR2_LINUX_2_6_BRCM
 	tristate
 	default m if CONFIG_DEVEL
 	depends BR2_PACKAGE_KMOD_USB_CONTROLLER
diff --git a/openwrt/target/linux/package/openswan/Config.in b/openwrt/target/linux/package/openswan/Config.in
index 59a943f8e4..52b52ba116 100644
--- a/openwrt/target/linux/package/openswan/Config.in
+++ b/openwrt/target/linux/package/openswan/Config.in
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_KMOD_OPENSWAN
 	prompt "kmod-openswan..................... Openswan kernel module"
+	prompt "kmod-openswan..................... Openswan kernel module (FIXME, does not build on 2.6/mipsel)" if BR2_LINUX_2_6_BRCM
 	tristate
 	default m if CONFIG_DEVEL
 	help