From: Felix Fietkau <nbd@openwrt.org>
Date: Thu, 7 Sep 2006 12:48:22 +0000 (+0000)
Subject: add extra rebuild check for development libraries
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=4ea7de50302b3f33a9ad2bcbda984161d0f3023b;p=openwrt%2Fstaging%2Fansuel.git

add extra rebuild check for development libraries

SVN-Revision: 4770
---

diff --git a/openwrt/include/package.mk b/openwrt/include/package.mk
index 515698d691..42ffcfbb3c 100644
--- a/openwrt/include/package.mk
+++ b/openwrt/include/package.mk
@@ -39,6 +39,10 @@ define Build/DefaultTargets
 	touch $$@
 
   ifdef Build/InstallDev
+    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed $(PKG_BUILD_DIR)),$(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed)
+      $(PKG_BUILD_DIR)/.built: package-rebuild
+    endif
+
     $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed: $(PKG_BUILD_DIR)/.built
 	mkdir -p $(STAGING_DIR)/stampfiles
 	$(call Build/InstallDev)