From: Steven Barth <cyrus@openwrt.org>
Date: Tue, 28 Apr 2015 14:58:54 +0000 (+0000)
Subject: odhcpd: Remove prefix class config option as not supported anymore by odhcpd
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=4fb99ec22f48dbf917bb10e1330136c990de6eea;p=openwrt%2Fstaging%2Fldir.git

odhcpd: Remove prefix class config option as not supported anymore by odhcpd

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>

SVN-Revision: 45586
---

diff --git a/package/network/services/odhcpd/Makefile b/package/network/services/odhcpd/Makefile
index 635a251123..22b9e38768 100644
--- a/package/network/services/odhcpd/Makefile
+++ b/package/network/services/odhcpd/Makefile
@@ -25,10 +25,6 @@ include $(INCLUDE_DIR)/cmake.mk
 
 CMAKE_OPTIONS += -DUBUS=1
 
-ifneq ($(CONFIG_PACKAGE_odhcpd_ext_prefix_class),0)
-  CMAKE_OPTIONS += -DEXT_PREFIX_CLASS=$(CONFIG_PACKAGE_odhcpd_ext_prefix_class)
-endif
-
 ifneq ($(CONFIG_PACKAGE_odhcpd_ext_cer_id),0)
   CMAKE_OPTIONS += -DEXT_CER_ID=$(CONFIG_PACKAGE_odhcpd_ext_cer_id)
 endif
@@ -42,10 +38,6 @@ define Package/odhcpd
 endef
 
 define Package/odhcpd/config
-  config PACKAGE_odhcpd_ext_prefix_class
-    int "Prefix Class Extension ID (0 = disabled)"
-    depends on PACKAGE_odhcpd
-    default 0
   config PACKAGE_odhcpd_ext_cer_id
     int "CER-ID Extension ID (0 = disabled)"
     depends on PACKAGE_odhcpd