From: Felix Fietkau <nbd@openwrt.org>
Date: Sun, 19 Jul 2015 14:59:09 +0000 (+0000)
Subject: strace: cross compile fix: pass HOST_*FLAGS in to ./configure
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=51ab7ade4e0e2a99e898510f093a3d96f75e7e35;p=openwrt%2Fstaging%2Fansuel.git

strace: cross compile fix: pass HOST_*FLAGS in to ./configure

The HOST_*FLAGS are for compiling programs which will run on the machine that is
running the build.  Setting these flags is frequently required for unusual
cross-compiles.

Signed-off-by: Lawrence D'Anna <larry@elder-gods.org>

SVN-Revision: 46422
---

diff --git a/package/devel/strace/Makefile b/package/devel/strace/Makefile
index eb80791b26..b9ed201bba 100644
--- a/package/devel/strace/Makefile
+++ b/package/devel/strace/Makefile
@@ -27,6 +27,12 @@ PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
+CONFIGURE_VARS+= \
+	LDFLAGS_FOR_BUILD="$(HOST_LDFLAGS)" \
+	CPPFLAGS_FOR_BUILD="$(HOST_CPPFLAGS)" \
+	CFLAGS_FOR_BUILD="$(HOST_CFLAGS)" \
+	CC_FOR_BUILD="$(HOST_CC)"
+
 define Package/strace
   SECTION:=utils
   CATEGORY:=Utilities