From: Zeyu Dong <dzy201415@gmail.com>
Date: Sat, 30 Sep 2023 00:54:58 +0000 (-0400)
Subject: build: cache kernel module package compiling
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=52751b12320599b557d8c7779b612102b963595d;p=openwrt%2Fstaging%2Fsvanheule.git

build: cache kernel module package compiling

Kernel module packages compiling is not cached (e.g. mac80211)
even with CONFIG_CCACHE on.

CC should be set to KERNEL_CC in KERNEL_MAKE_FLAGS at kernel.mk
to allow kernel module packages using ccache.

Signed-off-by: Zeyu Dong <dzy201415@gmail.com>
---

diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index a0527c0d28..d9842fd82a 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -9,10 +9,6 @@ endif
 
 INITRAMFS_EXTRA_FILES ?= $(GENERIC_PLATFORM_DIR)/image/initramfs-base-files.txt
 
-ifneq (,$(KERNEL_CC))
-  KERNEL_MAKEOPTS += CC="$(KERNEL_CC)"
-endif
-
 export HOST_EXTRACFLAGS=-I$(STAGING_DIR_HOST)/include
 
 # defined in quilt.mk
diff --git a/include/kernel.mk b/include/kernel.mk
index 3012eb8993..8236416132 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -119,6 +119,10 @@ KERNEL_MAKE_FLAGS = \
 	cmd_syscalls= \
 	$(if $(__package_mk),KBUILD_EXTRA_SYMBOLS="$(wildcard $(PKG_SYMVERS_DIR)/*.symvers)")
 
+ifneq (,$(KERNEL_CC))
+  KERNEL_MAKE_FLAGS += CC="$(KERNEL_CC)"
+endif
+
 KERNEL_NOSTDINC_FLAGS = \
 	-nostdinc $(if $(DUMP),, -isystem $(shell $(TARGET_CC) -print-file-name=include))