From: Florian Fainelli <florian@openwrt.org>
Date: Thu, 29 Oct 2009 23:34:39 +0000 (+0000)
Subject: ext2 images need to wait for /dev/sda2 to appear before attempting to mount it, fixes... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=540e328b6670a815950926929f303059998f1c66;p=openwrt%2Fstaging%2Flinusw.git

ext2 images need to wait for /dev/sda2 to appear before attempting to mount it, fixes olpc boot on ext2 images

SVN-Revision: 18215
---

diff --git a/target/linux/olpc/image/Makefile b/target/linux/olpc/image/Makefile
index eb1bedd0a0..f60b76e204 100644
--- a/target/linux/olpc/image/Makefile
+++ b/target/linux/olpc/image/Makefile
@@ -27,7 +27,7 @@ ifeq ($(CONFIG_OLPC_BOOTSCRIPT_IMAGES),y)
   endef
 
   define Image/cmdline/ext2
-    root=$(ROOTPART) rootfstype=ext2
+    root=$(ROOTPART) rootfstype=ext2 rootwait
   endef
 
   define Image/Build/bootscript