From: Felix Fietkau <nbd@openwrt.org>
Date: Mon, 20 Oct 2014 09:23:55 +0000 (+0000)
Subject: prereq-build: rename the openssl check to libssl, add back the old check - it is... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=549f7d0366170de48ce4061217f74bfab5d13472;p=openwrt%2Fstaging%2Frobimarko.git

prereq-build: rename the openssl check to libssl, add back the old check - it is required after all

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 42999
---

diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 4a87c9211a..5a743225f6 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -168,13 +168,17 @@ $(eval $(call RequireCommand,svn, \
 	Please install the subversion client. \
 ))
 
-define Require/openssl
+define Require/libssl
 	echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
 		gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl
 endef
 
-$(eval $(call Require,openssl, \
-	Please install openssl (with development headers) \
+$(eval $(call Require,libssl, \
+	Please install the openssl library (with development headers) \
+))
+
+$(eval $(call RequireCommand,openssl, \
+       Please install openssl. \
 ))
 
 define Require/gnu-find