From: Piotr Dymacz <pepe2k@gmail.com>
Date: Mon, 5 Feb 2018 17:57:55 +0000 (+0100)
Subject: ar71xx: image: simplify Embedded Wireless definitions
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=54b1be5f91f1b2fa1d59b1b86849e04ecae34668;p=openwrt%2Fstaging%2Fnbd.git

ar71xx: image: simplify Embedded Wireless definitions

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
---

diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 5a7b89e3c9..7440ba7975 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -358,22 +358,17 @@ endef
 TARGET_DEVICES += ew-balin
 
 define Device/ew-dorin
+  $(Device/ew-balin)
   DEVICE_TITLE := Embedded Wireless Dorin Platform
-  DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea
   BOARDNAME := EW-DORIN
   CONSOLE := ttyATH0,115200
-  IMAGE_SIZE := 16000k
-  MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),16000k(firmware),64k(art)ro
 endef
 TARGET_DEVICES += ew-dorin
 
 define Device/ew-dorin-router
+  $(Device/ew-dorin)
   DEVICE_TITLE := Embedded Wireless Dorin Router Platform
-  DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea
   BOARDNAME := EW-DORIN-ROUTER
-  CONSOLE := ttyATH0,115200
-  IMAGE_SIZE := 16000k
-  MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),16000k(firmware),64k(art)ro
 endef
 TARGET_DEVICES += ew-dorin-router