From: Steven Barth <cyrus@openwrt.org>
Date: Tue, 8 Sep 2015 17:44:17 +0000 (+0000)
Subject: iproute2: improve ip-full coexistence, remove rt_table
X-Git-Tag: reboot~2099
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=579fe7f52ab6c6d6ec6087901f8e5514cea4b4e8;p=openwrt%2Fstaging%2Fjogo.git

iproute2: improve ip-full coexistence, remove rt_table

Signed-off-by: Steven Barth <steven@midlink.org>

SVN-Revision: 46831
---

diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 7b55f695e8..cc73c1318b 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
 PKG_VERSION:=4.0.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/
@@ -39,10 +39,6 @@ endef
 
 Package/ip-full=$(call Package/iproute2/Default,full,Full)
 
-define Package/ip/conffiles
-/etc/iproute2/rt_tables
-endef
-
 define Package/ip-$(BUILD_VARIANT)/conffiles
 $(Package/ip/conffiles)
 endef
@@ -112,13 +108,12 @@ endef
 
 define Package/ip/install
 	$(INSTALL_DIR) $(1)/usr/sbin
-	$(INSTALL_DIR) $(1)/etc/iproute2
-	$(INSTALL_DATA) $(PKG_BUILD_DIR)/etc/iproute2/rt_tables $(1)/etc/iproute2
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/ip/ip $(1)/usr/sbin/
 endef
 
-define Package/ip-$(BUILD_VARIANT)/install
-	$(Package/ip/install)
+define Package/ip-full/install
+	$(INSTALL_DIR) $(1)/usr/bin
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/ip/ip $(1)/usr/bin/
 endef
 
 define Package/tc/install