From: Daniel Dickinson <crazycshore@gmail.com>
Date: Mon, 4 Apr 2011 11:29:59 +0000 (+0000)
Subject: block-mount: Fixed warning of missing /lib/functions/fsck during boot when no scripts... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=581793d2c465474ae2591b78f6bb3f26c22e51a2;p=openwrt%2Fstaging%2Faparcar.git

block-mount: Fixed warning of missing /lib/functions/fsck during boot when no scripts are installed in the directory. Thanks to Maarten Bezemer.

SVN-Revision: 26468
---

diff --git a/package/block-mount/Makefile b/package/block-mount/Makefile
index 05ca086d8e..ba19071b7b 100644
--- a/package/block-mount/Makefile
+++ b/package/block-mount/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=block-mount
 PKG_VERSION:=0.2.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -51,6 +51,7 @@ define Package/block-mount/install
 	$(INSTALL_DIR) $(1)/etc/config
 	$(INSTALL_DATA) ./files/fstab.config $(1)/etc/config/fstab
 	$(INSTALL_DIR) $(1)/lib/functions
+	$(INSTALL_DIR) $(1)/lib/functions/fsck
 	$(INSTALL_DATA) ./files/mount.sh $(1)/lib/functions/
 	$(INSTALL_DATA) ./files/fsck.sh $(1)/lib/functions/
 	$(INSTALL_DATA) ./files/block.sh $(1)/lib/functions/