From: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Date: Fri, 4 May 2018 17:27:48 +0000 (-0700)
Subject: at91: sdcard image with ext4 rootfs
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=581f5e239203df652f5a4b2ff7a22ab402735d8a;p=openwrt%2Fstaging%2Fansuel.git

at91: sdcard image with ext4 rootfs

creating sdcard image with ext4 rootfs only and ignoring creating
other filesystem in sdcard image.

Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
---

diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index ccaeebe7ca..93180dd64f 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -23,7 +23,7 @@ endif
 define Device/Default
   $(Device/default-nand)
   PROFILES := Default
-  FILESYSTEMS := squashfs ubifs
+  FILESYSTEMS := squashfs ubifs ext4
   DEVICE_DTS := $(1)
   KERNEL_NAME := zImage
   KERNEL_SIZE := 4096k
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index 5960f40a3b..fd7a53421e 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -4,6 +4,7 @@ FAT32_BLOCKS:=$(shell echo \
   $$(($(AT91_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
 define Build/at91-sdcard
+  $(if $(findstring ext4,$@), \
   rm -f $@.boot
   mkfs.fat -C $@.boot $(FAT32_BLOCKS)
 
@@ -30,7 +31,7 @@ define Build/at91-sdcard
 
   gzip -nc9 $@.img > $@
 
-  rm -f $@.img $@.boot
+  rm -f $@.img $@.boot )
 endef
 
 define Device/evaluation-sdimage