From: John Crispin <john@openwrt.org>
Date: Mon, 15 Feb 2016 18:45:34 +0000 (+0000)
Subject: kernel: add missing libphy dep to DSA
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=5902afcfca557872b76c7c4391b14ceb5273b7e2;p=openwrt%2Fstaging%2Fyousong.git

kernel: add missing libphy dep to DSA

Signed-off-by: John Crispin <blogic@openwrt.org>

SVN-Revision: 48723
---

diff --git a/package/kernel/linux/modules/dsa.mk b/package/kernel/linux/modules/dsa.mk
index 0696d754d5..5f19a3f7b4 100644
--- a/package/kernel/linux/modules/dsa.mk
+++ b/package/kernel/linux/modules/dsa.mk
@@ -18,6 +18,7 @@ define KernelPackage/dsa
 	CONFIG_NET_DSA \
 	CONFIG_NET_SWITCHDEV=y \
 	CONFIG_NET_DSA_HWMON=n
+  DEPENDS:=+kmod-libphy
   FILES:=$(LINUX_DIR)/net/dsa/dsa_core.ko
   AUTOLOAD:=$(call AutoLoad,34,dsa_core)
 endef