From: Hauke Mehrtens <hauke@hauke-m.de>
Date: Fri, 2 Nov 2018 23:27:55 +0000 (+0100)
Subject: kernel: Adapt to move of autofs4 in kernel 4.19
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=59065da6348459764cf15dfceb475e6f32f35c1e;p=openwrt%2Fstaging%2Fnbd.git

kernel: Adapt to move of autofs4 in kernel 4.19

autofs4 is now in the fs/autofs/ folder in kernel 4.19

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---

diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 619ae90bc8..edd2774a63 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -49,8 +49,12 @@ $(eval $(call KernelPackage,fs-afs))
 define KernelPackage/fs-autofs4
   SUBMENU:=$(FS_MENU)
   TITLE:=AUTOFS4 filesystem support
-  KCONFIG:=CONFIG_AUTOFS4_FS
-  FILES:=$(LINUX_DIR)/fs/autofs4/autofs4.ko
+  KCONFIG:= \
+	CONFIG_AUTOFS4_FS \
+	CONFIG_AUTOFS_FS
+  FILES:= \
+	$(LINUX_DIR)/fs/autofs4/autofs4.ko@lt4.18 \
+	$(LINUX_DIR)/fs/autofs/autofs4.ko@ge4.18
   AUTOLOAD:=$(call AutoLoad,30,autofs4)
 endef