From: Felix Fietkau <nbd@openwrt.org>
Date: Fri, 14 Apr 2006 04:27:05 +0000 (+0000)
Subject: port iptables to new config format, change handling of TITLE and DESCRIPTION
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=5a4980a72bf26150aa8c83f11b34bfd7ee4c7dd2;p=openwrt%2Fstaging%2Fthess.git

port iptables to new config format, change handling of TITLE and DESCRIPTION

SVN-Revision: 3647
---

diff --git a/openwrt/package/busybox/Makefile b/openwrt/package/busybox/Makefile
index 009a64a212..d1ce289354 100644
--- a/openwrt/package/busybox/Makefile
+++ b/openwrt/package/busybox/Makefile
@@ -18,8 +18,7 @@ define Package/busybox
 CONFIGFILE:=config/Config.in
 SECTION:=base
 CATEGORY:=Base system
-TITLE:=Core utilities
-DESCRIPTION:=Core utilities for embedded Linux systems
+TITLE:=Core utilities for embedded Linux
 endef
 
 define Build/Configure
diff --git a/openwrt/package/iptables/Makefile b/openwrt/package/iptables/Makefile
index f16ac8be48..ded4816b21 100644
--- a/openwrt/package/iptables/Makefile
+++ b/openwrt/package/iptables/Makefile
@@ -17,50 +17,129 @@ PKG_CAT:=bzcat
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-define IPKG_plugin_template
-
-$$(IPKG_$(1)):
-	install -m0755 -d $$(IDIR_$(1))/usr/lib/iptables
-	for m in $$(patsubst xt_%,ipt_%,$(2)); do \
-		$(CP) $(PKG_INSTALL_DIR)/usr/lib/iptables/lib$$$${m}.so $$(IDIR_$(1))/usr/lib/iptables/ ; \
-	done
-	@[ -z "$(3)" ] || $(MAKE) $(3)
-	$(RSTRIP) $$(IDIR_$(1))
-	$(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
-
-endef
+PKG_MENU:=IPv4 / IPv6 firewall administration
 
 include $(TOPDIR)/package/rules.mk
 include $(LINUX_DIR)/.config
 include $(TOPDIR)/target/linux/netfilter.mk
 
-$(eval $(call PKG_template,IPTABLES,iptables,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,IPTABLES_EXTRA,iptables-extra,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,IPTABLES_UTILS,iptables-utils,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,IP6TABLES,ip6tables,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(eval $(call PKG_template,IPTABLES_MOD_CONNTRACK,iptables-mod-conntrack,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,IPTABLES_MOD_EXTRA,iptables-mod-extra,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,IPTABLES_MOD_FILTER,iptables-mod-filter,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,IPTABLES_MOD_IMQ,iptables-mod-imq,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,IPTABLES_MOD_IPOPT,iptables-mod-ipopt,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,IPTABLES_MOD_IPSEC,iptables-mod-ipsec,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,IPTABLES_MOD_NAT,iptables-mod-nat,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,IPTABLES_MOD_ULOG,iptables-mod-ulog,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(eval $(call IPKG_plugin_template,IPTABLES_MOD_CONNTRACK,$(IPT_CONNTRACK-m)))
-$(eval $(call IPKG_plugin_template,IPTABLES_MOD_EXTRA,$(IPT_EXTRA-m)))
-$(eval $(call IPKG_plugin_template,IPTABLES_MOD_FILTER,$(IPT_FILTER-m),layer7-install))
-$(eval $(call IPKG_plugin_template,IPTABLES_MOD_IMQ,$(IPT_IMQ-m)))
-$(eval $(call IPKG_plugin_template,IPTABLES_MOD_IPOPT,$(IPT_IPOPT-m)))
-$(eval $(call IPKG_plugin_template,IPTABLES_MOD_IPSEC,$(IPT_IPSEC-m)))
-$(eval $(call IPKG_plugin_template,IPTABLES_MOD_NAT,$(IPT_NAT-m)))
-$(eval $(call IPKG_plugin_template,IPTABLES_MOD_ULOG,$(IPT_ULOG-m)))
-
-$(PKG_BUILD_DIR)/.configured:
-	touch $@
-
-$(PKG_BUILD_DIR)/.built:
+define Package/iptables
+SECTION:=net
+CATEGORY:=Base system
+TITLE:=IPv4 firewall administration tool
+endef
+
+define Package/iptables-mod-conntrack
+SECTION:=net
+CATEGORY:=Base system
+DEPENDS:=iptables
+TITLE:=iptables extensions for connection tracking
+DESCRIPTION:=Includes: \\\
+	* libipt_conntrack \\\
+	* libipt_helper \\\
+	* libipt_connmark/CONNMARK
+
+endef
+
+define Package/iptables-mod-filter
+SECTION:=net
+CATEGORY:=Base system
+DEPENDS:=iptables
+TITLE:=iptables extensions for packet content inspection
+DESCRIPTION:=Includes: \\\
+	* libipt_ipp2p \\\
+	* libipt_layer7 
+						
+endef
+
+define Package/iptables-mod-imq
+SECTION:=net
+CATEGORY:=Base system
+DEPENDS:=iptables
+TITLE:=iptables extension for IMQ support 
+DESCRIPTION:=Includes: \\\
+	* libipt_IMQ
+						
+endef
+
+define Package/iptables-mod-ipopt
+SECTION:=net
+CATEGORY:=Base system
+DEPENDS:=iptables
+TITLE:=iptables extensions for matching/changing IP packet options
+DESCRIPTION:=Includes: \\\
+	* libipt_dscp/DSCP \\\
+	* libipt_ecn/ECN \\\
+	* libipt_length \\\
+	* libipt_mac \\\
+	* libipt_tos/TOS \\\
+	* libipt_tcpmms \\\
+	* libipt_ttl/TTL \\\
+	* libipt_unclean 
+
+endef
+
+define Package/iptables-mod-ipsec
+SECTION:=net
+CATEGORY:=Base system
+DEPENDS:=iptables
+TITLE:=iptables extensions for matching ipsec traffic
+DESCRIPTION:=Includes: \\\
+	* libipt_ah \\\
+	* libipt_esp
+
+endef
+
+define Package/iptables-mod-nat
+SECTION:=net
+CATEGORY:=Base system
+DEPENDS:=iptables
+TITLE:=iptables extensions for different NAT targets
+DESCRIPTION:=Includes: \\\
+	* libipt_REDIRECT
+endef
+
+define Package/iptables-mod-ulog
+SECTION:=net
+CATEGORY:=Base system
+DEPENDS:=iptables
+TITLE:=iptables extensions for user-space packet logging
+DESCRIPTION:=Includes: \\\
+	* libipt_ULOG
+endef
+
+define Package/iptables-mod-extra
+SECTION:=net
+CATEGORY:=Base system
+DEPENDS:=iptables
+TITLE:=other extra iptables extensions
+DESCRIPTION:=Includes: \\\
+	* libipt_limit \\\
+	* libipt_owner \\\
+	* libipt_physdev \\\
+	* libipt_pkttype \\\
+	* libipt_recent
+
+endef
+
+define Package/iptables-utils
+SECTION:=net
+CATEGORY:=Base system
+DEPENDS:=iptables
+TITLE:=iptables save and restore utilities
+endef
+
+define Package/ip6tables
+SECTION:=net
+CATEGORY:=Base system
+TITLE:=IPv6 firewall administration tool
+endef
+
+
+define Build/Configure
+endef
+
+define Build/Compile
 	chmod a+x $(PKG_BUILD_DIR)/extensions/.*-test*
 	mkdir -p $(PKG_INSTALL_DIR)
 	$(MAKE) -C $(PKG_BUILD_DIR) \
@@ -69,43 +148,70 @@ $(PKG_BUILD_DIR)/.built:
 		KERNEL_DIR=$(LINUX_DIR) PREFIX=/usr \
 		DESTDIR="$(PKG_INSTALL_DIR)" \
 		all install install-devel
-	touch $@
+endef
 		
-$(IPKG_IPTABLES):
-	install -d -m0755 $(IDIR_IPTABLES)/etc/config
-	install -m0644 ./files/firewall.config $(IDIR_IPTABLES)/etc/config/firewall
-	install -d -m0755 $(IDIR_IPTABLES)/etc/init.d
-	install -m0755 ./files/firewall.init $(IDIR_IPTABLES)/etc/init.d/S45firewall
-	install -m0755 ./files/firewall.user $(IDIR_IPTABLES)/etc/
-	install -d -m0755 $(IDIR_IPTABLES)/usr/lib
-	install -m0644 ./files/firewall.awk $(IDIR_IPTABLES)/usr/lib
-	install -d -m0755 $(IDIR_IPTABLES)/usr/sbin
-	$(CP) $(PKG_INSTALL_DIR)/usr/sbin/iptables $(IDIR_IPTABLES)/usr/sbin/
-	install -d -m0755 $(IDIR_IPTABLES)/usr/lib/iptables
+define Package/iptables/install
+	install -d -m0755 $(1)/etc/config
+	install -m0644 ./files/firewall.config $(1)/etc/config/firewall
+	install -d -m0755 $(1)/etc/init.d
+	install -m0755 ./files/firewall.init $(1)/etc/init.d/S45firewall
+	install -m0755 ./files/firewall.user $(1)/etc/
+	install -d -m0755 $(1)/usr/lib
+	install -m0644 ./files/firewall.awk $(1)/usr/lib
+	install -d -m0755 $(1)/usr/sbin
+	$(CP) $(PKG_INSTALL_DIR)/usr/sbin/iptables $(1)/usr/sbin/
+	install -d -m0755 $(1)/usr/lib/iptables
 	(cd $(PKG_INSTALL_DIR)/usr/lib/iptables ; \
-		$(CP) $(patsubst %,lib%.so,$(IPT_BUILTIN:xt_%=ipt_%)) $(IDIR_IPTABLES)/usr/lib/iptables/ \
+		$(CP) $(patsubst %,lib%.so,$(IPT_BUILTIN:xt_%=ipt_%)) $(1)/usr/lib/iptables/ \
 	)
-	$(RSTRIP) $(IDIR_IPTABLES)
-	$(IPKG_BUILD) $(IDIR_IPTABLES) $(PACKAGE_DIR)
-
-$(IPKG_IPTABLES_EXTRA):
-	$(IPKG_BUILD) $(IDIR_IPTABLES_EXTRA) $(PACKAGE_DIR)
-
-$(IPKG_IPTABLES_UTILS):
-	install -d -m0755 $(IDIR_IPTABLES_UTILS)/usr/sbin
-	$(CP) $(PKG_INSTALL_DIR)/usr/sbin/iptables-{save,restore} $(IDIR_IPTABLES_UTILS)/usr/sbin/
-	$(RSTRIP) $(IDIR_IPTABLES_UTILS)
-	$(IPKG_BUILD) $(IDIR_IPTABLES_UTILS) $(PACKAGE_DIR)
-
-$(IPKG_IP6TABLES):
-	install -d -m0755 $(IDIR_IP6TABLES)/usr/sbin
-	$(CP) $(PKG_INSTALL_DIR)/usr/sbin/ip6tables $(IDIR_IP6TABLES)/usr/sbin/
-	install -d -m0755 $(IDIR_IP6TABLES)/usr/lib/iptables
+	$(RSTRIP) $(1)
+endef
+
+define Package/iptables-utils/install
+	install -d -m0755 $(1)/usr/sbin
+	$(CP) $(PKG_INSTALL_DIR)/usr/sbin/iptables-{save,restore} $(1)/usr/sbin/
+	$(RSTRIP) $(1)
+endef
+
+define Package/ip6tables/install
+	install -d -m0755 $(1)/usr/sbin
+	$(CP) $(PKG_INSTALL_DIR)/usr/sbin/ip6tables $(1)/usr/sbin/
+	install -d -m0755 $(1)/usr/lib/iptables
 	(cd $(PKG_INSTALL_DIR)/usr/lib/iptables ; \
-		$(CP) libip6t_*.so $(IDIR_IP6TABLES)/usr/lib/iptables/ \
+		$(CP) libip6t_*.so $(1)/usr/lib/iptables/ \
 	)
-	$(RSTRIP) $(IDIR_IP6TABLES)
-	$(IPKG_BUILD) $(IDIR_IP6TABLES) $(PACKAGE_DIR)
+	$(RSTRIP) $(1)
+endef
+
+$(eval $(call BuildPackage,iptables))
+$(eval $(call BuildPackage,iptables-utils))
+$(eval $(call BuildPackage,ip6tables))
+
+define BuildPlugin
+define Package/$(1)/install
+	install -m0755 -d $$(1)/usr/lib/iptables
+	for m in $$(patsubst xt_%,ipt_%,$(2)); do \
+		$(CP) $(PKG_INSTALL_DIR)/usr/lib/iptables/lib$$$$$$$${m}.so $$(1)/usr/lib/iptables/ ; \
+	done
+	$(3)
+	$(RSTRIP) $$(1)
+endef
+
+$$(eval $$(call BuildPackage,$(1)))
+endef
+
+L7_INSTALL:=mkdir -p $$(1)/etc/l7-protocols; \
+	$(CP) files/l7/*.pat $$(1)/etc/l7-protocols/
+
+$(eval $(call BuildPlugin,iptables-mod-conntrack,$(IPT_CONNTRACK-m)))
+$(eval $(call BuildPlugin,iptables-mod-extra,$(IPT_EXTRA-m)))
+$(eval $(call BuildPlugin,iptables-mod-filter,$(IPT_FILTER-m),$(L7_INSTALL)))
+$(eval $(call BuildPlugin,iptables-mod-imq,$(IPT_IMQ-m)))
+$(eval $(call BuildPlugin,iptables-mod-ipopt,$(IPT_IPOPT-m)))
+$(eval $(call BuildPlugin,iptables-mod-ipsec,$(IPT_IPSEC-m)))
+$(eval $(call BuildPlugin,iptables-mod-nat,$(IPT_NAT-m)))
+$(eval $(call BuildPlugin,iptables-mod-ulog,$(IPT_ULOG-m)))
+
 
 $(STAGING_DIR)/usr/lib/libipq.a: $(PKG_BUILD_DIR)/.built
 	mkdir -p $(STAGING_DIR)/usr/include
@@ -113,15 +219,11 @@ $(STAGING_DIR)/usr/lib/libipq.a: $(PKG_BUILD_DIR)/.built
 	mkdir -p $(STAGING_DIR)/usr/lib
 	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libipq.a $(STAGING_DIR)/usr/lib/
 
-layer7-install:
-	mkdir -p $(IDIR_IPTABLES_MOD_FILTER)/etc/l7-protocols
-	$(CP) files/l7/*.pat $(IDIR_IPTABLES_MOD_FILTER)/etc/l7-protocols/
-
 install-dev: $(STAGING_DIR)/usr/lib/libipq.a
-
 uninstall-dev:
 	rm -rf $(STAGING_DIR)/usr/include/libipq.h
 	rm -rf $(STAGING_DIR)/usr/lib/libipq.a
 
 compile-targets: install-dev
 clean-targets: uninstall-dev
+
diff --git a/openwrt/package/iptables/ipkg/ip6tables.control b/openwrt/package/iptables/ipkg/ip6tables.control
deleted file mode 100644
index c6d63936e3..0000000000
--- a/openwrt/package/iptables/ipkg/ip6tables.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: ip6tables
-Priority: optional
-Depends: kmod-ip6tables
-Section: net
-Description: The netfilter firewalling software for IPv6
diff --git a/openwrt/package/iptables/ipkg/iptables-extra.control b/openwrt/package/iptables/ipkg/iptables-extra.control
deleted file mode 100644
index afd4235c42..0000000000
--- a/openwrt/package/iptables/ipkg/iptables-extra.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: iptables-extra
-Priority: optional
-Section: net
-Depends: iptables, iptables-mod-conntrack, iptables-mod-extra, iptables-mod-filter, iptables-mod-ipopt, iptables-mod-ipsec, iptables-mod-nat, iptables-mod-ulog
-Description: Other extra Iptables extensions (meta-package)
diff --git a/openwrt/package/iptables/ipkg/iptables-mod-conntrack.control b/openwrt/package/iptables/ipkg/iptables-mod-conntrack.control
deleted file mode 100644
index 840992e677..0000000000
--- a/openwrt/package/iptables/ipkg/iptables-mod-conntrack.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: iptables-mod-conntrack
-Priority: optional
-Section: net
-Depends: iptables, kmod-ipt-conntrack
-Description: Iptables (IPv4) extensions for connection tracking
diff --git a/openwrt/package/iptables/ipkg/iptables-mod-extra.control b/openwrt/package/iptables/ipkg/iptables-mod-extra.control
deleted file mode 100644
index f26b4a4582..0000000000
--- a/openwrt/package/iptables/ipkg/iptables-mod-extra.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: iptables-mod-extra
-Priority: optional
-Section: net
-Depends: iptables, kmod-ipt-extra
-Description: Other extra Iptables (IPv4) extensions
diff --git a/openwrt/package/iptables/ipkg/iptables-mod-filter.control b/openwrt/package/iptables/ipkg/iptables-mod-filter.control
deleted file mode 100644
index 43ec799557..0000000000
--- a/openwrt/package/iptables/ipkg/iptables-mod-filter.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: iptables-mod-filter
-Priority: optional
-Section: net
-Depends: iptables, kmod-ipt-filter
-Description: Iptables (IPv4) extension for packet content inspection
diff --git a/openwrt/package/iptables/ipkg/iptables-mod-imq.control b/openwrt/package/iptables/ipkg/iptables-mod-imq.control
deleted file mode 100644
index d1e46d28a0..0000000000
--- a/openwrt/package/iptables/ipkg/iptables-mod-imq.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: iptables-mod-imq
-Priority: optional
-Section: net
-Depends: kmod-imq
-Description: Iptables (IPv4) extensions for Intermediate Queuing Device QoS-support
diff --git a/openwrt/package/iptables/ipkg/iptables-mod-ipopt.control b/openwrt/package/iptables/ipkg/iptables-mod-ipopt.control
deleted file mode 100644
index 51ec6b20ab..0000000000
--- a/openwrt/package/iptables/ipkg/iptables-mod-ipopt.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: iptables-mod-ipopt
-Priority: optional
-Section: net
-Depends: iptables, kmod-ipt-ipopt
-Description: Iptables (IPv4) extensions for matching/changing IP packet options
diff --git a/openwrt/package/iptables/ipkg/iptables-mod-ipsec.control b/openwrt/package/iptables/ipkg/iptables-mod-ipsec.control
deleted file mode 100644
index 4b4d2e6383..0000000000
--- a/openwrt/package/iptables/ipkg/iptables-mod-ipsec.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: iptables-mod-ipsec
-Priority: optional
-Section: net
-Depends: iptables, kmod-ipt-ipsec
-Description: Iptables (IPv4) extensions for matching special IPsec packets
diff --git a/openwrt/package/iptables/ipkg/iptables-mod-nat.control b/openwrt/package/iptables/ipkg/iptables-mod-nat.control
deleted file mode 100644
index 2ebbb1cf77..0000000000
--- a/openwrt/package/iptables/ipkg/iptables-mod-nat.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: iptables-mod-nat
-Priority: optional
-Section: net
-Depends: iptables, kmod-ipt-nat
-Description: Iptables (IPv4) extensions for different NAT targets
diff --git a/openwrt/package/iptables/ipkg/iptables-mod-ulog.control b/openwrt/package/iptables/ipkg/iptables-mod-ulog.control
deleted file mode 100644
index 3fcd26fedf..0000000000
--- a/openwrt/package/iptables/ipkg/iptables-mod-ulog.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: iptables-mod-ulog
-Priority: optional
-Section: net
-Depends: iptables, kmod-ipt-ulog
-Description: Iptables (IPv4) extension for user-space packet logging
diff --git a/openwrt/package/iptables/ipkg/iptables-utils.control b/openwrt/package/iptables/ipkg/iptables-utils.control
deleted file mode 100644
index aff5f4d778..0000000000
--- a/openwrt/package/iptables/ipkg/iptables-utils.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: iptables-utils
-Priority: optional
-Section: net
-Depends: iptables
-Description: iptables-save and iptables-restore for Iptables (IPv4)
diff --git a/openwrt/package/iptables/ipkg/iptables.control b/openwrt/package/iptables/ipkg/iptables.control
deleted file mode 100644
index 40a6523b75..0000000000
--- a/openwrt/package/iptables/ipkg/iptables.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: iptables
-Priority: optional
-Section: net
-Description: The netfilter firewalling software for IPv4
diff --git a/openwrt/package/rules.mk b/openwrt/package/rules.mk
index 0920f7bcf3..c2f0a34511 100644
--- a/openwrt/package/rules.mk
+++ b/openwrt/package/rules.mk
@@ -56,13 +56,13 @@ IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
 IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
 INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
 
-ifneq ($(BR2_PACKAGE_$(1)),)
+ifneq ($(PACKAGE_$(1)),)
 compile-targets: $$(IPKG_$(1))
 endif
 ifneq ($(DEVELOPER),)
 compile-targets: $$(IPKG_$(1))
 endif
-ifeq ($(BR2_PACKAGE_$(1)),y)
+ifeq ($(PACKAGE_$(1)),y)
 install-targets: $$(INFO_$(1))
 endif
 
@@ -78,7 +78,8 @@ $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
 	echo "Priority: $$(PRIORITY)" >> $$(IDIR_$(1))/CONTROL/control
 	echo "Maintainer: $$(MAINTAINER)" >> $$(IDIR_$(1))/CONTROL/control
 	echo "Architecture: $$(PKGARCH)" >> $$(IDIR_$(1))/CONTROL/control
-	echo "Description: $$(DESCRIPTION)" >> $$(IDIR_$(1))/CONTROL/control
+	echo "Description: $$(TITLE)" >> $$(IDIR_$(1))/CONTROL/control
+	echo "$$(DESCRIPTION)" | sed -e 's,\\,\n ,g' >> $$(IDIR_$(1))/CONTROL/control
 	chmod 644 $$(IDIR_$(1))/CONTROL/control
 	for file in conffiles preinst postinst prerm postrm; do \
 		[ -f ./ipkg/$(1).$$$$file ] && cp ./ipkg/$(1).$$$$file $$(IDIR_$(1))/CONTROL/$$$$file || true; \