From: Rafał Miłecki <zajec5@gmail.com>
Date: Tue, 21 Apr 2015 08:42:41 +0000 (+0000)
Subject: bcm53xx: image: prepare for generating serial flash images
X-Git-Tag: reboot~3197
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=5b9d70c888a53082f70d36909ca82f9f2b215b34;p=openwrt%2Fstaging%2Fblogic.git

bcm53xx: image: prepare for generating serial flash images

There are some rare devices without NAND, like Netgear EX6200 or
TP-LINK Archer C8.

Signed-off-by: Rafał Miłecki <zajec5@gmail.com>

SVN-Revision: 45545
---

diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index fb909c4629b3..b299f38949ff 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -34,6 +34,13 @@ define Build/mkfs/squashfs
 	( cd $(KDIR); $(STAGING_DIR_HOST)/bin/ubinize -p 128KiB -m 2048 -o $(KDIR)/root-block-0x20000-min-0x800.ubi ubinize.cfg )
 endef
 
+define Build/trx-serial
+	$(STAGING_DIR_HOST)/bin/trx \
+		-o $@ \
+		-f $(word 1,$^) -a 1024 \
+		-f $(KDIR)/root.squashfs -a 0x10000 -A $(KDIR)/fs_mark
+endef
+
 define Build/trx-nand
 	# kernel: always use 4 MiB (-28 B or TRX header) to allow upgrades even
 	#	  if it grows up between releases