From: Sven Wegener <sven.wegener@stealer.net>
Date: Thu, 17 Dec 2015 10:59:24 +0000 (+0100)
Subject: toolchain: fix dangling symlink to self in FixupLibdir
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=5c04efd2d7d9432f75843c3fd472458ad37d203d;p=openwrt%2Fstaging%2Fjogo.git

toolchain: fix dangling symlink to self in FixupLibdir

This avoids a dangling symlink to self when reinstalling the toolchain:

./staging_dir/toolchain-mips_24kc_gcc-9.3.0_musl/lib/lib -> lib

This is caused by the fact that in the toolchain dir we have

'lib64 -> lib'

and on executing

'ln lib ./staging_dir/toolchain-mips_24kc_gcc-9.3.0_musl/lib64'

ln dereference the symbolic link 'lib64' to 'lib' so the REAL command is

'ln lib ./staging_dir/toolchain-mips_24kc_gcc-9.3.0_musl/lib'

this results in the dangling symlink to self.

Signed-off-by: Sven Wegener <sven.wegener@stealer.net>
[ add more details to the commit description and fix title ]
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
---

diff --git a/include/toolchain-build.mk b/include/toolchain-build.mk
index b7a253b71b..87ba8313df 100644
--- a/include/toolchain-build.mk
+++ b/include/toolchain-build.mk
@@ -18,6 +18,6 @@ define FixupLibdir
 		mkdir -p $(1)/lib; \
 		mv $(1)/lib64/* $(1)/lib/; \
 		rm -rf $(1)/lib64; \
+		ln -sf lib $(1)/lib64; \
 	fi
-	ln -sf lib $(1)/lib64
 endef