From: Hauke Mehrtens <hauke@hauke-m.de>
Date: Sat, 28 Apr 2018 22:39:38 +0000 (+0200)
Subject: uboot-zynq: Fix build with libressl 2.7.2
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=5ca159ab3b36c97197bff6a50f65e1666a8f78ec;p=openwrt%2Fstaging%2Fansuel.git

uboot-zynq: Fix build with libressl 2.7.2

When libressl was linked the libpthread was missing, add it in addition.

Fixes: 2c192b69163f ("tools/libressl: update to version 2.7.2")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---

diff --git a/package/boot/uboot-zynq/patches/210-link-libcrypto-static.patch b/package/boot/uboot-zynq/patches/210-link-libcrypto-static.patch
new file mode 100644
index 0000000000..a260e84e80
--- /dev/null
+++ b/package/boot/uboot-zynq/patches/210-link-libcrypto-static.patch
@@ -0,0 +1,14 @@
+OpenWrt links the libressl statically against mkimage, make sure all the 
+needed dependencies are added too.
+
+--- a/tools/Makefile
++++ b/tools/Makefile
+@@ -128,7 +128,7 @@ endif
+ # MXSImage needs LibSSL
+ ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CONFIG_FIT_SIGNATURE),)
+ HOSTLOADLIBES_mkimage += \
+-	$(shell pkg-config --libs libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
++	$(shell pkg-config --libs --static libssl libcrypto 2> /dev/null || echo "-lssl -lpthread -lcrypto")
+ 
+ # OS X deprecate openssl in favour of CommonCrypto, supress deprecation
+ # warnings on those systems