From: Gabor Juhos <juhosg@openwrt.org>
Date: Tue, 21 Feb 2012 09:44:30 +0000 (+0000)
Subject: ramips: raeth: add missing Kconfig and Makefile
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=5e6bc97d0ccd3fbf82e03896f8d5987f534ce19e;p=openwrt%2Fstaging%2Fneocturne.git

ramips: raeth: add missing Kconfig and Makefile

SVN-Revision: 30671
---

diff --git a/target/linux/ramips/files/drivers/net/ethernet/ramips/Kconfig b/target/linux/ramips/files/drivers/net/ethernet/ramips/Kconfig
new file mode 100644
index 0000000000..08d7ad170c
--- /dev/null
+++ b/target/linux/ramips/files/drivers/net/ethernet/ramips/Kconfig
@@ -0,0 +1,13 @@
+config NET_RAMIPS
+       tristate "Ralink RT288X/RT3X5X/RT3662/RT3883 ethernet driver"
+       depends on MIPS_RALINK
+       select PHYLIB if (SOC_RT288X || SOC_RT3883)
+       help
+         This driver supports the etehrnet mac inside the ralink wisocs
+
+if NET_RAMIPS
+
+config NET_RAMIPS_DEBUG
+       bool "Enable debug messages in the Ralink ethernet driver"
+
+endif
diff --git a/target/linux/ramips/files/drivers/net/ethernet/ramips/Makefile b/target/linux/ramips/files/drivers/net/ethernet/ramips/Makefile
new file mode 100644
index 0000000000..db4a58f0e9
--- /dev/null
+++ b/target/linux/ramips/files/drivers/net/ethernet/ramips/Makefile
@@ -0,0 +1,5 @@
+#
+# Makefile for the Ramips SoCs built-in ethernet macs
+#
+
+obj-$(CONFIG_NET_RAMIPS)	+= ramips.o