From: Jo-Philipp Wich <jow@openwrt.org>
Date: Tue, 5 Jun 2012 17:48:41 +0000 (+0000)
Subject: base-files: ship a static initial shadow db instead of creating it from passwd with... 
X-Git-Tag: reboot~13697
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=5e84df6bac701e442ec877fd1dc140bab9803c75;p=openwrt%2Fstaging%2Fblogic.git

base-files: ship a static initial shadow db instead of creating it from passwd with sed, this fixes registering of users at compile time

SVN-Revision: 32064
---

diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index a74d83cac6d2..68c8e0233bec 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -443,10 +443,6 @@ define Package/base-files/install
 			$(CP) $(PLATFORM_SUBDIR)/$(PROFILE)/base-files/* $(1)/; \
 		fi \
 	)
-# Form valid /etc/shadow entries, by copying the user:pw pairs
-# from /etc/passwd, and adding on pw change data
-	cut -d ':' -f 1-2 $(1)/etc/passwd > $(1)/etc/shadow; \
-	$(SED) 's/$$$$/:0:0:99999:7:::/' $(1)/etc/shadow
 
 	$(VERSION_SED) \
 		$(1)/etc/banner \
diff --git a/package/base-files/files/etc/shadow b/package/base-files/files/etc/shadow
new file mode 100644
index 000000000000..e9898901b274
--- /dev/null
+++ b/package/base-files/files/etc/shadow
@@ -0,0 +1,5 @@
+root:x:0:0:99999:7:::
+daemon:*:0:0:99999:7:::
+ftp:*:0:0:99999:7:::
+network:*:0:0:99999:7:::
+nobody:*:0:0:99999:7:::