From: Florian Fainelli <f.fainelli@gmail.com>
Date: Tue, 14 Dec 2021 20:27:43 +0000 (-0800)
Subject: bcm47xx: Fix Netgear WNR3500L v2 image format
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=5f108050941b467f9911ef75e7ccf4401fd1d5c0;p=openwrt%2Fstaging%2Fjogo.git

bcm47xx: Fix Netgear WNR3500L v2 image format

CFE on these devices expects to find the kernel compressed with LZMA but
with no dictionnary and no loader, adjust the image generation
accordingly.

Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
---

diff --git a/target/linux/bcm47xx/image/mips74k.mk b/target/linux/bcm47xx/image/mips74k.mk
index 53e7b53eba..7e65821a55 100644
--- a/target/linux/bcm47xx/image/mips74k.mk
+++ b/target/linux/bcm47xx/image/mips74k.mk
@@ -460,6 +460,8 @@ define Device/netgear_wnr3500l-v2
   $(Device/netgear)
   NETGEAR_BOARD_ID := U12H172T00_NETGEAR
   NETGEAR_REGION := 1
+  KERNEL_NAME = vmlinux-nodictionary.lzma
+  IMAGE/chk := append-rootfs | trx-without-loader | netgear-chk
 endef
 TARGET_DEVICES += netgear_wnr3500l-v2