From: Hauke Mehrtens <hauke@hauke-m.de>
Date: Sat, 28 Apr 2018 16:20:20 +0000 (+0200)
Subject: tools/make-ext4fs: Fix build on MacOSX
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=60427a940f084efea7fbfc3f072dc4cff80b7e33;p=openwrt%2Fstaging%2Fansuel.git

tools/make-ext4fs: Fix build on MacOSX

MacOSX does not support "-Wl,-Bstatic" so do not force the static
linking.
We only copy the static libz library into the staging libraries
directories, the linker will anyway only find the static version and
link against that on all systems.

Fixes: 8dcd941d8b9 ("tools/zlib: move zlib build to tools")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---

diff --git a/tools/make-ext4fs/Makefile b/tools/make-ext4fs/Makefile
index 97f9e6369c..f67ab6e5b5 100644
--- a/tools/make-ext4fs/Makefile
+++ b/tools/make-ext4fs/Makefile
@@ -17,8 +17,6 @@ PKG_MIRROR_HASH:=d7ccd5e426b1d15331ff000a37dc15161f6eef594453e970fd584fcde5a2507
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_MAKE_FLAGS += STATIC=1
-
 define Host/Install
 	$(INSTALL_BIN) $(HOST_BUILD_DIR)/make_ext4fs $(STAGING_DIR_HOST)/bin/
 endef