From: Florian Fainelli <florian@openwrt.org>
Date: Tue, 28 Feb 2006 07:31:29 +0000 (+0000)
Subject: Added support for : save-password( --enable-password-save), smaller executable (... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=62cb331e8ebc7fdcea9726eaf9974780cc3179d7;p=openwrt%2Fstaging%2Flinusw.git

Added support for : save-password( --enable-password-save), smaller executable (--enable-small)

SVN-Revision: 3284
---

diff --git a/openwrt/package/openvpn/Config.in b/openwrt/package/openvpn/Config.in
index 860a39f034..3feffa3016 100644
--- a/openwrt/package/openvpn/Config.in
+++ b/openwrt/package/openvpn/Config.in
@@ -38,4 +38,16 @@ config BR2_COMPILE_OPENVPN_WITH_LZO
 	depends BR2_PACKAGE_OPENVPN
 	select BR2_PACKAGE_LIBLZO
 
+config BR2_COMPILE_OPENVPN_WITH_PASSWORD_SAVE
+	prompt "Enable password saving"
+	bool
+	default y
+	depends BR2_PACKAGE_OPENVPN
+
+config BR2_COMPILE_OPENVPN_WITH_SMALL
+	prompt "Enable smaller executable size (disable OCC, usage message, and verb 4 parm list)"
+	bool
+	default n
+	depends BR2_PACKAGE_OPENVPN
+
 endmenu
diff --git a/openwrt/package/openvpn/Makefile b/openwrt/package/openvpn/Makefile
index e5e1275841..5ae1a31200 100644
--- a/openwrt/package/openvpn/Makefile
+++ b/openwrt/package/openvpn/Makefile
@@ -38,6 +38,12 @@ endif
 ifneq ($(BR2_COMPILE_OPENVPN_WITH_HTTP),y)
 DISABLE_HTTP:=--disable-http
 endif
+ifeq ($(BR2_COMPILE_OPENVPN_WITH_PASSWORD_SAVE),y)
+ENABLE_PASSWORD_SAVE:=--enable-password-save
+endif
+ifeq ($(BR2_COMPILE_OPENVPN_WITH_SMALL),y)
+ENABLE_SMALL:=--enable-small
+endif
 
 $(PKG_BUILD_DIR)/.configured:
 	(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
@@ -76,6 +82,8 @@ $(PKG_BUILD_DIR)/.configured:
 		  $(DISABLE_OPENSSL) \
 		  $(DISABLE_SERVER) \
 		  $(DISABLE_HTTP) \
+		  $(ENABLE_PASSWORD_SAVE) \
+		  $(ENABLE_SMALL) \
 	);
 	touch $(PKG_BUILD_DIR)/.configured