From: Robert Marko <robimarko@gmail.com>
Date: Mon, 2 Apr 2018 22:44:43 +0000 (+0200)
Subject: ath3k: Add firmware support for QCA Rome
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=6390f27c2ed6189f6aac2308a2ea40fde2f798d7;p=openwrt%2Fstaging%2Fdedeckeh.git

ath3k: Add firmware support for QCA Rome

Add needed firmware for newer QCA Rome Bluetooth family.
This enables use of bluetooth with ath3k driver on QCA9377/9378 devices.

Signed-off-by: Robert Marko <robimarko@gmail.com>
---

diff --git a/package/firmware/linux-firmware/qca.mk b/package/firmware/linux-firmware/qca.mk
index 0a809d1a21..23fcc0905a 100644
--- a/package/firmware/linux-firmware/qca.mk
+++ b/package/firmware/linux-firmware/qca.mk
@@ -4,6 +4,10 @@ define Package/ar3k-firmware/install
 	$(CP) \
 		$(PKG_BUILD_DIR)/ar3k/*.dfu \
 		$(1)/lib/firmware/ar3k
+	$(INSTALL_DIR) $(1)/lib/firmware/qca
+	$(CP) \
+		$(PKG_BUILD_DIR)/qca/*.bin \
+		$(1)/lib/firmware/qca
 endef
 $(eval $(call BuildPackage,ar3k-firmware))