From: Felix Fietkau <nbd@openwrt.org>
Date: Fri, 8 Dec 2006 04:06:29 +0000 (+0000)
Subject: minor cleanup
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=65ce91ec4116f07bf03830169563d1d4ad0fc123;p=openwrt%2Fstaging%2Fblocktrron.git

minor cleanup

SVN-Revision: 5718
---

diff --git a/include/image.mk b/include/image.mk
index 70677b9c2f..1c36327c61 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -75,10 +75,12 @@ define Image/mkfs/prepare
 endef
 
 define BuildImage
-compile:
+download:
+prepare:
+compile: compile-targets
 	$(call Build/Compile)
 
-install:
+install: compile install-targets
 	$(call Image/Prepare)
 	$(call Image/mkfs/prepare)
 	$(call Image/BuildKernel)
@@ -87,16 +89,12 @@ install:
 	$(call Image/mkfs/tgz)
 	$(call Image/mkfs/ext2)
 	
-clean:
+clean: clean-targets
 	$(call Build/Clean)
-endef
 
 compile-targets:
 install-targets:
 clean-targets:
+endef
+
 
-download:
-prepare:
-compile: compile-targets
-install: compile install-targets
-clean: clean-targets