From: Felix Fietkau <nbd@nbd.name>
Date: Mon, 23 Jan 2017 12:40:15 +0000 (+0100)
Subject: build: use if-then to avoid non-zero return codes in bin/ packaging code
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=6699f58fdbfd74cd3206bd1bc3311e395204ba30;p=openwrt%2Fstaging%2Fldir.git

build: use if-then to avoid non-zero return codes in bin/ packaging code

Signed-off-by: Felix Fietkau <nbd@nbd.name>
---

diff --git a/include/package-bin.mk b/include/package-bin.mk
index 68f5831340..4ae049af54 100644
--- a/include/package-bin.mk
+++ b/include/package-bin.mk
@@ -29,10 +29,10 @@ ifeq ($(DUMP),)
     install-bin-$(1): $(PKG_BUILD_DIR)/.pkgdir/$(1).installed
 	rm -rf $(BIN_DIR)/$(1)
 	-rmdir $(PKG_BUILD_DIR)/.pkgdir/$(1) >/dev/null 2>/dev/null
-	[ -d $(PKG_BUILD_DIR)/.pkgdir/$(1) ] && { \
+	if [ -d $(PKG_BUILD_DIR)/.pkgdir/$(1) ]; then \
 		$(INSTALL_DIR) $(BIN_DIR)/$(1) && \
 		$(CP) $(PKG_BUILD_DIR)/.pkgdir/$(1)/. $(BIN_DIR)/$(1)/; \
-	}
+	fi
 
     clean-$(1):
 	  rm -rf $(BIN_DIR)/$(1)