From: Luka Perkov <luka@openwrt.org>
Date: Wed, 17 Jul 2013 22:24:45 +0000 (+0000)
Subject: base-files/busybox: move ntpd init script from base-files to busybox
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=67f1d364b8fde1247f02eec0a2da108848922665;p=openwrt%2Fstaging%2Fansuel.git

base-files/busybox: move ntpd init script from base-files to busybox

SVN-Revision: 37383
---

diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index fa2081f8d4..3bdb0a8d3f 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=141
+PKG_RELEASE:=142
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/etc/init.d/sysntpd b/package/base-files/files/etc/init.d/sysntpd
deleted file mode 100755
index c40ee76da3..0000000000
--- a/package/base-files/files/etc/init.d/sysntpd
+++ /dev/null
@@ -1,31 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2011 OpenWrt.org
-
-START=98
-
-USE_PROCD=1
-PROG=/usr/sbin/ntpd
-SERVICE_PID_FILE=/var/run/sysntpd.pid
-
-start_service() {
-	local peers
-	local args="-n"
-	local enable_server
-
-	config_load system
-	config_get peers ntp server
-	config_get_bool enable_server ntp enable_server 0
-
-	[ $enable_server -eq 0 -a -z "$peers" ] && return
-
-	procd_open_instance
-	procd_set_param command "$PROG" -n
-        [ $enable_server -ne 0 ] && procd_append_param command -l
-	[ -n "$peers" ] && {
-		local peer
-		for peer in $peers; do
-			procd_append_param command -p $peer
-		done
-	}
-	procd_close_instance
-}
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index aed6ddea6b..0b2778ffd9 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.19.4
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -37,6 +37,7 @@ endif
 
 init-y :=
 init-$(CONFIG_BUSYBOX_CONFIG_CROND) += cron
+init-$(CONFIG_BUSYBOX_CONFIG_NTPD) += ntp
 init-$(CONFIG_BUSYBOX_CONFIG_TELNETD) += telnet
 
 define Package/busybox
diff --git a/package/utils/busybox/files/ntp b/package/utils/busybox/files/ntp
new file mode 100755
index 0000000000..c40ee76da3
--- /dev/null
+++ b/package/utils/busybox/files/ntp
@@ -0,0 +1,31 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2011 OpenWrt.org
+
+START=98
+
+USE_PROCD=1
+PROG=/usr/sbin/ntpd
+SERVICE_PID_FILE=/var/run/sysntpd.pid
+
+start_service() {
+	local peers
+	local args="-n"
+	local enable_server
+
+	config_load system
+	config_get peers ntp server
+	config_get_bool enable_server ntp enable_server 0
+
+	[ $enable_server -eq 0 -a -z "$peers" ] && return
+
+	procd_open_instance
+	procd_set_param command "$PROG" -n
+        [ $enable_server -ne 0 ] && procd_append_param command -l
+	[ -n "$peers" ] && {
+		local peer
+		for peer in $peers; do
+			procd_append_param command -p $peer
+		done
+	}
+	procd_close_instance
+}