From: Jo-Philipp Wich <jow@openwrt.org>
Date: Wed, 25 Apr 2012 13:43:15 +0000 (+0000)
Subject: kernel: fix packaging of 8250.ko with Linux 3.x This commit fixes build breakage... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=68a6a13517532f16727755664818734ebcf1ffb9;p=openwrt%2Fstaging%2Fansuel.git

kernel: fix packaging of 8250.ko with Linux 3.x This commit fixes build breakage in package/kernel leading to missing subsequent kmods like kmod-usb-serial, this should fix the missing packages in ar71xx builds.

SVN-Revision: 31477
---

diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index abac4811d4..d3450cf73b 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -896,7 +896,15 @@ define KernelPackage/serial-8250
 	CONFIG_SERIAL_8250_SHARE_IRQ=y \
 	CONFIG_SERIAL_8250_DETECT_IRQ=n \
 	CONFIG_SERIAL_8250_RSA=n
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.3)),1)
+  FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/8250.ko
+else
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.38)),1)
   FILES:=$(LINUX_DIR)/drivers/tty/serial/8250.ko
+ else
+  FILES:=$(LINUX_DIR)/drivers/serial/8250.ko
+ endif
+endif
 endef
 
 define KernelPackage/serial-8250/description