From: Gabor Juhos <juhosg@openwrt.org>
Date: Fri, 10 Feb 2012 08:19:23 +0000 (+0000)
Subject: kernel: update linux 3.2 to 3.2.5
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=69593176911e2ca512d526c91300df1fd2b42bc0;p=openwrt%2Fstaging%2Fnbd.git

kernel: update linux 3.2 to 3.2.5

SVN-Revision: 30401
---

diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index a37edf29d5..66aca0dfeb 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -35,8 +35,8 @@ endif
 ifeq ($(LINUX_VERSION),3.1.10)
   LINUX_KERNEL_MD5SUM:=3649bdaa50ffd9114cc16486ec54d83a
 endif
-ifeq ($(LINUX_VERSION),3.2.2)
-  LINUX_KERNEL_MD5SUM:=c0303125c8eda431b10084eece7564e3
+ifeq ($(LINUX_VERSION),3.2.5)
+  LINUX_KERNEL_MD5SUM:=17c180eaa524101ca1c675bd675eca37
 endif
 
 # disable the md5sum check for unknown kernel versions
diff --git a/target/linux/au1000/Makefile b/target/linux/au1000/Makefile
index f619df5bb2..1ce821bb1a 100644
--- a/target/linux/au1000/Makefile
+++ b/target/linux/au1000/Makefile
@@ -13,7 +13,7 @@ FEATURES:=jffs2 usb pci
 SUBTARGETS=au1500 au1550
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.2.2
+LINUX_VERSION:=3.2.5
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini yamonenv
diff --git a/target/linux/ep93xx/Makefile b/target/linux/ep93xx/Makefile
index 84e4671121..5a6121db5a 100644
--- a/target/linux/ep93xx/Makefile
+++ b/target/linux/ep93xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb
 CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.2.2
+LINUX_VERSION:=3.2.5
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/generic/patches-3.2/020-ssb_update.patch b/target/linux/generic/patches-3.2/020-ssb_update.patch
index ca686f361c..1fe1768f1a 100644
--- a/target/linux/generic/patches-3.2/020-ssb_update.patch
+++ b/target/linux/generic/patches-3.2/020-ssb_update.patch
@@ -184,12 +184,10 @@
  #define SSB_SPROM8_CCK2GPO		0x0140	/* CCK power offset */
  #define SSB_SPROM8_OFDM2GPO		0x0142	/* 2.4GHz OFDM power offset */
  #define SSB_SPROM8_OFDM5GPO		0x0146	/* 5.3GHz OFDM power offset */
-@@ -502,6 +553,46 @@
- #define SSB_BFL2_SPUR_WAR		0x0200	/* has a workaround for clock-harmonic spurs */
- #define SSB_BFL2_GPLL_WAR		0x0400	/* altenative G-band PLL settings implemented */
+@@ -464,6 +515,46 @@
  
-+/* Values for boardflags_lo read from SPROM */
-+#define SSB_BFL_BTCOEXIST		0x0001	/* implements Bluetooth coexistance */
+ /* Values for boardflags_lo read from SPROM */
+ #define SSB_BFL_BTCOEXIST		0x0001	/* implements Bluetooth coexistance */
 +#define SSB_BFL_PACTRL			0x0002	/* GPIO 9 controlling the PA */
 +#define SSB_BFL_AIRLINEMODE		0x0004	/* implements GPIO 13 radio disable indication */
 +#define SSB_BFL_RSSI			0x0008	/* software calculates nrssi slope. */
@@ -228,6 +226,8 @@
 +#define SSB_BFL2_SPUR_WAR		0x0200	/* has a workaround for clock-harmonic spurs */
 +#define SSB_BFL2_GPLL_WAR		0x0400	/* altenative G-band PLL settings implemented */
 +
- /* Values for SSB_SPROM1_BINF_CCODE */
- enum {
- 	SSB_SPROM1CCODE_WORLD = 0,
++/* Values for boardflags_lo read from SPROM */
++#define SSB_BFL_BTCOEXIST		0x0001	/* implements Bluetooth coexistance */
+ #define SSB_BFL_PACTRL			0x0002	/* GPIO 9 controlling the PA */
+ #define SSB_BFL_AIRLINEMODE		0x0004	/* implements GPIO 13 radio disable indication */
+ #define SSB_BFL_RSSI			0x0008	/* software calculates nrssi slope. */
diff --git a/target/linux/omap4/Makefile b/target/linux/omap4/Makefile
index 16a5a34ef0..63ac069d6a 100644
--- a/target/linux/omap4/Makefile
+++ b/target/linux/omap4/Makefile
@@ -11,7 +11,7 @@ BOARD:=omap4
 BOARDNAME:=TI OMAP4
 FEATURES:=usb targz audio display
 
-LINUX_VERSION:=3.2.2
+LINUX_VERSION:=3.2.5
 CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>