From: Stijn Tintel <stijn@linux-ipv6.be>
Date: Fri, 21 Oct 2016 14:50:39 +0000 (+0300)
Subject: ar71xx: build relocate stub for generic and legacy images
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=6b0d279ca58bf6173b57c7e9b759be4552eab74a;p=openwrt%2Fstaging%2Fzorun.git

ar71xx: build relocate stub for generic and legacy images

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Acked-by: John Crispin <john@phrozen.org>
---

diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 56e07d82f3..26e955840a 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -79,8 +79,11 @@ define Build/loader-okli
 endef
 
 define Build/relocate-kernel
+	rm -rf $(KDIR)/relocate
+	$(CP) ../../generic/image/relocate $(KDIR)
+	$(MAKE) -C $(KDIR)/relocate KERNEL_ADDR=$(KERNEL_LOADADDR) CROSS_COMPILE=$(TARGET_CROSS)
 	( \
-		dd if=$(KDIR)/relocate.bin bs=32 conv=sync && \
+		dd if=$(KDIR)/relocate/loader.bin bs=32 conv=sync && \
 		perl -e '@s = stat("$@"); print pack("N", @s[7])' && \
 		cat "$@" \
 	) > "$@.new"
diff --git a/target/linux/ar71xx/image/legacy.mk b/target/linux/ar71xx/image/legacy.mk
index ec28fcbe77..08305da3ea 100644
--- a/target/linux/ar71xx/image/legacy.mk
+++ b/target/linux/ar71xx/image/legacy.mk
@@ -1097,12 +1097,6 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
 	$(call Image/BuildLoader,generic,elf,,,-initramfs)
 endif
 	$(call Image/BuildLoader,generic,elf)
-
-	# Note: not only used for legacy images
-	rm -rf $(KDIR)/relocate
-	$(CP) ../../generic/image/relocate $(KDIR)
-	$(MAKE) -C $(KDIR)/relocate KERNEL_ADDR=$(KERNEL_LOADADDR) CROSS_COMPILE=$(TARGET_CROSS)
-	$(CP) $(KDIR)/relocate/loader.bin $(KDIR)/relocate.bin
 endef
 
 define Image/Prepare/Profile