From: Nicolas Thill <nico@openwrt.org>
Date: Sun, 20 Apr 2008 09:49:13 +0000 (+0000)
Subject: build the kmod-video-quickcam module only if it was selected
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=6b8489761c8cef3c4573018971d9f64b210cfb75;p=openwrt%2Fstaging%2Fdangole.git

build the kmod-video-quickcam module only if it was selected

SVN-Revision: 10881
---

diff --git a/package/qc-usb/Makefile b/package/qc-usb/Makefile
index 1d57ccb664..8fd666809a 100644
--- a/package/qc-usb/Makefile
+++ b/package/qc-usb/Makefile
@@ -58,7 +58,8 @@ ifeq ($(KERNEL),2.4)
   endif
 endif
 
-define Build/Compile
+ifneq ($(CONFIG_PACKAGE_kmod-video-quickcam),)
+  define Build/Compile/kmod
 	$(MAKE) -C $(PKG_BUILD_DIR) \
 		LINUX_DIR="$(LINUX_DIR)" \
 		ARCH="$(LINUX_KARCH)" \
@@ -67,11 +68,20 @@ define Build/Compile
 		LD="$(TARGET_CC) -nodefaultlibs -nostartfiles" \
 		USER_OPT="$(KERNEL_C_OPTS)" \
 		quickcam.$(LINUX_KMOD_SUFFIX)
+  endef
+endif
+
+define Build/Compile/user
 	$(MAKE) -C $(PKG_BUILD_DIR) \
 		CFLAGS="$(TARGET_CFLAGS)" \
 		qcset
 endef
 
+define Build/Compile
+	$(call Build/Compile/kmod)
+	$(call Build/Compile/user)
+endef
+
 define Package/qc-usb-utils/install
 	$(INSTALL_DIR) $(1)/usr/bin
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/qcset $(1)/usr/bin/