From: Felix Fietkau <nbd@openwrt.org>
Date: Sun, 26 Jul 2015 11:42:27 +0000 (+0000)
Subject: image: fix device variable exports for initramfs images
X-Git-Tag: reboot~2376
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=6bb13be4f0309d6da0ed1d64d4b628468b93c3d5;p=openwrt%2Fopenwrt.git

image: fix device variable exports for initramfs images

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 46496
---

diff --git a/include/image.mk b/include/image.mk
index a20e090fe7..470a5dafeb 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -392,6 +392,7 @@ endef
 
 ifndef IB
 define Device/Build/initramfs
+  $(call Device/Export,$(KDIR)/tmp/$$(KERNEL_INITRAMFS_IMAGE),$(1))
   $$(_TARGET): $(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE)
 
   $(KDIR)/$$(KERNEL_NAME)-initramfs: image_prepare
@@ -439,7 +440,6 @@ endef
 define Device/Build/image
   $$(_TARGET): $(BIN_DIR)/$(call IMAGE_NAME,$(1),$(2))
   $(eval $(call Device/Export,$(KDIR)/$(KERNEL_IMAGE),$(1)))
-  $(eval $(call Device/Export,$(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE),$(1)))
   $(eval $(call Device/Export,$(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2)),$(1)))
   $(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2)): $(KDIR)/$$(KERNEL_IMAGE) $(KDIR)/root.$(1)
 	@rm -f $$@