From: Florian Fainelli <florian@openwrt.org>
Date: Thu, 13 Apr 2006 14:12:04 +0000 (+0000)
Subject: Add fakeidentd a lightweight identd daemon. Fix minor typo in menuconfig for weechat
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=6e0e080e315ac9fde89495183c939ab5f491ad1c;p=openwrt%2Fstaging%2Fthess.git

Add fakeidentd a lightweight identd daemon. Fix minor typo in menuconfig for weechat

SVN-Revision: 3631
---

diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index 8cea28903a..3a123aa8f9 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -85,6 +85,7 @@ source "package/elhttp/Config.in"
 source "package/ether-wake/Config.in"
 source "package/ethtool/Config.in"
 source "package/ez-ipupdate/Config.in"
+source "package/fakeidentd/Config.in"
 source "package/fping/Config.in"
 source "package/fprobe/Config.in"
 source "package/fprobe-ulog/Config.in"
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 4da2eb1874..4d0f0046f5 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -49,6 +49,7 @@ package-$(BR2_PACKAGE_ELINKS) += elinks
 package-$(BR2_PACKAGE_ETHER_WAKE) += ether-wake
 package-$(BR2_COMPILE_EXPAT) += expat
 package-$(BR2_PACKAGE_EZIPUPDATE) += ez-ipupdate
+package-$(BR2_PACKAGE_FAKEIDENTD) += fakeidentd
 package-$(BR2_PACKAGE_FETCHMAIL) += fetchmail
 package-$(BR2_COMPILE_FLAC) += flac
 package-$(BR2_PACKAGE_FPING) += fping
diff --git a/openwrt/package/fakeidentd/Config.in b/openwrt/package/fakeidentd/Config.in
new file mode 100644
index 0000000000..ddfa3a9992
--- /dev/null
+++ b/openwrt/package/fakeidentd/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_FAKEIDENTD
+	prompt "fakeidentd........................ A static, secure identd."
+	tristate
+	default m if CONFIG_DEVEL
+	help
+	  A static secure identd, only one source file.
+	
+	  http://www.guru-group.fi/~too/sw/releases/
diff --git a/openwrt/package/fakeidentd/Makefile b/openwrt/package/fakeidentd/Makefile
new file mode 100644
index 0000000000..fa61f35366
--- /dev/null
+++ b/openwrt/package/fakeidentd/Makefile
@@ -0,0 +1,37 @@
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=fakeidentd
+PKG_VERSION:=2.2
+PKG_RELEASE:=1
+PKG_MD5SUM:=aa4133981c94c59868344cd3b02e8e19
+
+PKG_SOURCE_URL:=http://distfiles.gentoo.org/distfiles/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_CAT:=bzcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,FAKEIDENTD,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+	touch $@
+
+$(PKG_BUILD_DIR)/.built:
+	$(TARGET_CC) -o $(PKG_BUILD_DIR)/$(PKG_NAME) $(PKG_BUILD_DIR)/identd.c
+	touch $@
+
+$(IPKG_FAKEIDENTD):
+	install -d -m0755 $(IDIR_FAKEIDENTD)/usr/sbin \
+			  $(IDIR_FAKEIDENTD)/etc/init.d \
+			  $(IDIR_FAKEIDENTD)/etc/default/
+	echo $(whoami) > $(IDIR_FAKEIDENTD)/etc/default/$(PKG_NAME)
+	$(CP) $(PKG_BUILD_DIR)/fakeidentd $(IDIR_FAKEIDENTD)/usr/sbin/
+	$(CP) ./files/$(PKG_NAME).init $(IDIR_FAKEIDENTD)/etc/init.d/$(PKG_NAME)
+	$(RSTRIP) $(IDIR_FAKEIDENTD)
+	$(IPKG_BUILD) $(IDIR_FAKEIDENTD) $(PACKAGE_DIR)
+
diff --git a/openwrt/package/fakeidentd/files/fakeidentd.init b/openwrt/package/fakeidentd/files/fakeidentd.init
new file mode 100644
index 0000000000..954ad8c24c
--- /dev/null
+++ b/openwrt/package/fakeidentd/files/fakeidentd.init
@@ -0,0 +1,18 @@
+#!/bin/sh
+NAME=fakeidentd
+case "$1" in
+  start)
+	[ -e $DEFAULT ] && $NAME $DEFAULT
+	;;
+  stop)
+        killall $NAME
+	;;
+  restart)
+	killall $NAME
+	$NAME
+	;;
+  *)
+	echo "Usage: $NAME (start|stop|restart)" > 2&
+	exit 1
+	;;
+esac
diff --git a/openwrt/package/fakeidentd/ipkg/fakeidentd.control b/openwrt/package/fakeidentd/ipkg/fakeidentd.control
new file mode 100644
index 0000000000..6c528b2752
--- /dev/null
+++ b/openwrt/package/fakeidentd/ipkg/fakeidentd.control
@@ -0,0 +1,4 @@
+Package: fakeidentd
+Description: A static, secure identd.
+Section: net
+Priority: optional
diff --git a/openwrt/package/weechat/Config.in b/openwrt/package/weechat/Config.in
index ea24124cbf..810345a3b2 100644
--- a/openwrt/package/weechat/Config.in
+++ b/openwrt/package/weechat/Config.in
@@ -1,4 +1,4 @@
-menu "weechat................................. Lightweight IRC client"
+menu "weechat........................... Lightweight IRC client"
 
 config BR2_PACKAGE_WEECHAT
 	prompt "weechat.......................... Lightweight IRC client"